1

enter image description here

For some reason one of my attribute tables appears to have created a graphic and is overlayed on my maps. It only happens when zoomed out 1:1,250,000 or more. I have removed all layers to see if it is linked to any an it doesn't appear to be. This is a big project so I would rather not have to create it again, particularly if the problem will persist. The text is present in both layout and data view.

Has anyone seen this before, know what it is and how to remove? How can I stop this from happening again?

closed as off-topic by PolyGeo Sep 19 '16 at 2:22

This question appears to be off-topic. The users who voted to close gave this specific reason:

  • "This problem cannot or can no longer be reproduced. Changes to the system or to the asker's circumstances may have rendered the question obsolete, or the question does not include a procedure to enable potential answerers to reproduce the same symptoms. Such questions are off-topic as they are unlikely to help future readers, but editing them to include more details can lead to re-opening." – PolyGeo
If this question can be reworded to fit the rules in the help center, please edit the question.

  • Based on what you are showing there, it doesn't look like the attribute table itself was copied. I say this because none of the records are lined up in even columns. It looks like you somehow copied all the records you had, as in from a text file, and pasted them in to the data view as text elements. Can you draw a window around a few of them and select and delete them? – Get Spatial May 8 '15 at 17:14
  • It is the text from one of my tribute tables. I created the layer as a random sample of a much larger layer already in the project. I can't select any of the text. It re sizes it's self when zoomed. – Ben May 8 '15 at 17:39
  • Did you try selecting it with the Data Frame focused? – landocalrissian May 8 '15 at 18:07
  • Thanks for the help. Think I'll have to load the layers into a new project and hope the problem doesn't persist. If it does I'll be back. – Ben May 8 '15 at 18:18
  • funny, this just happened to me, or something like it. Is it not just a text graphic in data view that you can select and delete? – mr.adam May 8 '15 at 22:44
0

I cannot see any other text elements on the layout that you have pictured.

Consequently, I think you should check Layout View first:

  1. Make sure that you are in Layout View
  2. Use the Select Elements tool from the Tools toolbar to click inside the area of text which I am thinking must be a Text Element. It should get a blue border to indicate that it is selected.
  3. Hit the Delete key

If that does not work, then check Data View as suggested by @Zack in their comment:

You seem to have copy-pasted the text into the data frame, as I did. The method that successfully selected the element for deletion was to navigate to edit>"select all elements". Then I was able to delete. Another option is to hide the text. Right click your data frame>properties>annotation groups. Uncheck the correct group (presumably "default") and you are done!

Not the answer you're looking for? Browse other questions tagged or ask your own question.