0

When I try to replace values in a field with Greek Characters they appear as it should be in attribute, but when I save the edits and re open the attribute I see question mark.

The same thing happens also in Qgis 2.8.1.

I use windows 7 x64 ultimate.

On an other machine which runs windows 8.1 and ArcGis 10.2.1 I see the replaced Greek letters and after reopen the attribute but when I export the attribute in .dbf I don't see anything.

How can I fix this problem?

1

There are multiple reason for this problem and here are some tips.

If you are using Shape file make sure dbf is encoded in proper encoding i.e. UTF-8 or 1253 and you have install the keyboard language support (Greek) to windows as well. You can find these steps here.

http://www.howtogeek.com/howto/12578/add-keyboard-languages-to-xp-vista-and-windows-7/

My personal preference for this kind of stuff is FileGeoDB format. Once everything is OK in FileGeoDB then I export it to shapfile using write encoding setting in the registry.

You must read the following ESRI paper which explains how ArcGIS deal with the DBF encoding.

http://support.esri.com/cn/knowledgebase/techarticles/detail/21106

hope that helps.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.