3

I would like to test which nightly build between QGIS 1.8 and 2.0 caused a certain change in QGIS behavior. I know that there are very convenient exe files of weekly builds available on http://qgis.org/downloads/weekly/ . Yet, their temporal scope is limited. They do not go back in time enough for my purposes.

The archive at http://download2.osgeo.org/osgeo4w/release/qgis/qgis-dev/ goes back to the very beginnings, but offers only *.tar.bz2 format. Is it possible to use them with osgeo4W "local directory" installation? I have tried with the current osgeo4W version, but the files I downloaded to the local qgis_dev subdirectory were not recognized (osgeo4w continues to offer only the most recent and the previous versions for install). I have downloaded also an old 1.8 osgeo4w version but it does not have the GUI and I do not know what to write in the command line in order to install 1.9 nightly builds.

Well, I really hope there is something more convenient than to compile the source code "manually" according to the methods described on github.

2

Well, I found out what I was looking for. The easiest (at least concerning Windows) seems to be osgeo4W:

1) Open osgeo4w->Advanced Install->Download without Installing. Choose the local directory and after finishing the install, close osgeo4w.

2) Download the old nightly build files from the archive http://download2.osgeo.org/osgeo4w/release/qgis/qgis-dev/ into the local directory where the standard osgeo4w files were copied in point 1 (subdirectory: \x86\release\qgis\qgis-dev).

3) Edit the ini file in the /x86 subdirectory with updating the [prev] tag of the "qgi-dev" paragraph with the correct version, file name, correct size and correct MD5 hash of the archived qgis-dev file. In order to produce the MD5 hash see: https://superuser.com/questions/245775/is-there-a-built-in-checksum-utility-on-windows-7.

4) Open again osgeo4w->Advanced Install->Install from Local Directory->....->Select packages/Desktop/qgis-dev (click the entry in the column "new" until the intended file version appears)->Next->Finish

Ready. The old QGIS nightly build was installed! When openning it, there was a python error, but since I wanted to test the OGR provider, the python had no influence on my test.

I suppose that other osgeo4w libraries and dependencies could be also installed using the same procedure.

  • Can you add which GDAL, PROJ and Python versions are reported from the running QGIS-dev? Your approach may fail if the binaries expect a dependency not available on OSGEO4W anymore. – AndreJ May 13 '15 at 15:26
  • The last qgis-dev I have installed is 1.9.0-368 and it reports following values under Help->About: GDAL/OGR 1.9.2, PROJ.4 version 480. Where can I find the info about Python version? Perhaps I have none, since the initial error is saying: "Couldn't load PyQGIS. Python support will be disabled." If some dependency is not met, could one add it to the local osgeo4w directories and to the ini file with the same approach described above? – Pavol May 13 '15 at 19:26
  • @AndreJ - Typing "python" in the osgeo4w shell gives following version: Python 2.7.4 – Pavol May 14 '15 at 12:26
0

If you can provide a clear test case and all info/files needed, it might be easier to get some of the developers to bisect the versions for you.

QGIS heavily relies on other libraries and software, so it might be a better idea to try older versions of the whole OSGEO4W installation?

  • Yes, I have tried older versions of the whole OSGEO4W installation. With that I can tell that the change occurred between 1.8 and 2.0 QGIS version. But since it is not obvious even to the developers on the qgis_dev mailing list what code caused the change I described, I think the best would be just to try the 1.8 osgeo4w with 1.9 nightly builds. – Pavol May 11 '15 at 9:36
  • 1
    There have been a lot of changes between QGIS 1.8 and 2.0, which made it necessary to use a completely new user folder (.qgis2 instead of .qgis) and rewrite of all plugins. It is hard to tell if the desired dev-version is closer to QGIS 1.8 or 2.0. – AndreJ May 11 '15 at 11:50
  • I see. So what would be the best way to proceed when checking those dev-versions? – Pavol May 11 '15 at 12:41
  • You could try to implantate the qgis-dev binaries into an old QGIS 1.8 or 2.0 standalone installation. But I have not tried that myself. – AndreJ May 14 '15 at 6:47
  • Do you mean replacing the qgis.exe and qgis-core.dll or similar? – Pavol May 14 '15 at 14:06

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.