1

Creating layout in composer I am facing a problem of dislocation of a shapefile and a Google Earth image (which I am using from "OpenLayers plugin") Version 2.4.0 Chugiak (Mac).

In the first image shows the situation of map composer QGIS. Everything is correct and I just wanted the same output, but when I save it as PDF or JPEG or something, the shapefile layer is seen as a bit moved..!

Just want to get the exact same image which I am getting in the composer!

like this !!

  • Welcome. It would probably help if you can use some text to explain exactly what problem you have. – BradHards May 12 '15 at 7:10
  • thanks buddy in the first image shows the situation of map composer QGIS. Everything is correct and I just wanted the same output, but when I save it as pdf or jpeg or something, the shape file layer is seen as a bit moved..! just want to get the exact same image which I am getting in the composer ! – Razi May 12 '15 at 7:15
  • I think you should edit the question - if there are a few comments, some of them disappear. – BradHards May 12 '15 at 7:27
  • The OpenLayers plugin isn't compatible with the print composer. See hub.qgis.org/issues/5827, hub.qgis.org/issues/8824, ... – ndawson May 12 '15 at 22:43
1

The best workaround for this is to first of all go back into the normal QGIS data viewer. Turn off all your vector layers and additional raster layers if any so that you only have the Google Earth image open as your base layer.

Next go to "Project" tab and select "Save As Image...", this will save your data extent as a fully georeferenced image.

The final step is to load your newly saved image into QGIS and turn off your original Google Earth open layer base map.

Hope this helps.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.