3

There's a similar but not-quite-equivalent discussion here: Exporting symbology from ArcGIS Desktop to ArcGIS Online?

The people in that discussion, from 2011 to 2014, were using AGOL and trying to upload layers with symbology included. I'm using a free individual account and trying to upload a custom image to symbolize a layer already displayed. The interface seems to offer that option, but it doesn't respond as it should:

Oh God why isn't it working

I've clicked on the "use an image" link indicated in the screencap. In most interfaces this opens Finder, Windows Explorer, or similar. In this interface all it does is open an input box. I've tried pasting in the entire file path to Marker.png. However, clicking on the blue circle containing the white plus sign, I consistently get:

"Unable to load image."

The image is a simple .png with transparent background, 120 x 120 pixels. I've tried Chrome and Firefox. Anyone have any ideas?

  • Last time I did this (over a year ago) I had to have my symbols available on a web server. I put my images in the public folder of my dropbox.com account and referenced them from there. I dont know if there is support to upload and host the symbols in arcgis.com. – KHibma May 12 '15 at 13:13
  • Thank you for the excellent suggestion, but it doesn't seem to work. I tried both Google Drive and DropBox, making sure the file sharing was set to 'public'. I then got the link to the image and pasted it into the input box in the interface. Got the same result: "Unable to load image." What are you using? I'm running OSX 10.6.8. I've tried this in Firefox 37.0.2 and Chrome 42.0.2311.152 (64-bit). I suppose I could switch over to BootCamp and see if that works better. In the meantime, I'm open to suggestions. – M. Prescott May 16 '15 at 5:20
  • I have managed to get a PNG to work...my problem has been to save it. After I log out, and then back in, my marker set is never saved. I have stored the imaged on the ArcGIS Online server...it still never seems to save. Ideas? – Mark Oct 27 '15 at 15:41
  • This seems to be a new question , not an answer – Mapperz Oct 27 '15 at 16:03
  • If you have a new question, please ask it by clicking the Ask Question button. Include a link to this question if it helps provide context. – John Powell Oct 27 '15 at 16:15
1

I used Wikimedia to upload a PNG file of about 120 pixels x 120 pixels. After uploading the image onto Wikimedia, I click on the image and copied the "File URL" and pasted that into the "Use an Image" space to change a symbol in ArcGIS Online. It finally worked for me that way!

  • Thanks for your response. But what's your OS and browser? That may be part of the picture. – M. Prescott Aug 12 '15 at 9:03
1

I also have had trouble. Jpegs and gifs do not seem to work and I get the same message: "Unable to load image". Oddly, when I converted my image to a .png, uploaded to my site, and punched in the address, problem solved...image loaded ::shrug::

  • Thanks for your response. What OS and browser are you using? – M. Prescott Aug 12 '15 at 9:01
0

I used Inkscape to create a PNG and then loaded it under "custom Images" in the dropdown. I'm not sure if there is a file size limit. My PNG was only 1 KB. It worked fine for me.

I'm using a HTTP file server to store the image. My browser is Firefox.

0

I was having the same issues.

Once I started hosting my ".png" images using "imgur" it started working. The URL that did the trick came from the "Direct Links" option.

0

Upload your images/icons to ArcGIS online contents then share them publicly. After sharing with the public you will see a URL for the image that can be used in the "Use an image" box.

This should work!

enter image description here

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.