1

Working with ArcSDE 10.1 and Oracle spatial 11g.

I set the feature class in load_only_io before loading shapefiles. I am using geoprocessing tool (append) in ArcGIS to load shapefile to geodatabase. After loading ArcGIS is creating spatial index on sdo_geometry.

How to disable this automatic index creation?

I want to load shapefiles and later I want to create index myself.

  • Please edit the question to include the exact methodology you are using to populate the table. – Vince May 13 '15 at 10:52
1

As per Documentation:

With ArcSDE, putting a feature class in load-only mode disables updating of the spatial index while data is loading. In a File Geodatabase, putting a feature class or table in load-only mode disables updating of spatial and attribute indexes while data is loading. Taking the feature class or table out of load-only mode rebuilds the indexes.

Therefore to prevent from index rebuild (or creation), don't take your FC out of load-only mode. After loading all the features, turn off the load-only mode.

If you don't like this behavior, you should manually drop any spatial indexes and insert all rows/features and then create the index manually yourself.

  • I am not taking FC out of load_only mode, but it creates spatial index – Jaya Sudha May 14 '15 at 12:25
  • With load-only-mode, you need to acquire a schema lock (ISchemaLock). once you release the lock, load only mode will be turned off! – Farid Cheraghi May 14 '15 at 12:50
  • 1
    I am loading shape file using append geoprocessing tool – Jaya Sudha May 15 '15 at 4:16
  • Any suggestions on this problem ?? – Jaya Sudha Jun 11 '15 at 5:27

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.