Arc Catalog 10 - ArcInfo - Database Severs - Add Database Server: "Add an ArcSDE Personal or Workgroup database server by typing in the SQL Server Express instance you wish to connect to."

I want to connect to an MS SQL Server 2008 R2 Developer (like Enterprise) server on another machine, but it sounds like I cannot do that from here. If I try it anyway I get the message, "Connections to this edition of the database server are not supported."

My keycodes file for licensing has "svrenterprise" in it, so I don't know why I cannot connect to this database server. I want to make a direct connection to the database server, through the open port 1433, not 5151 SDE port.

1 Answer 1


You are using the wrong option, you need to use the 'Database Connections' versus 'Database Servers' option. You can setup 'A Spatial Database Connection' from here.

  • I see, under "Database Connections" I tried adding one of each type of connection. The OLDE DB Connection works and I can see the tables in my geodatabase, which was copied from the older server to this new one. But when I use "Add Spatial Database Connection" it connects to the default instance, but I don't see anything else listed in the contents. BTW were you with VF1 Wolfpack? They were with us back when I was on the USS Ranger. Miss those F-14s.
    – Bratch
    Sep 16, 2011 at 22:19
  • This URL help.arcgis.com/en/arcgisdesktop/10.0/help/index.html#/… gives you the basic info for doing a Direct-Connect, which you can easily connect to a different instance. I have Dev and Test instances on the same machine. BTW: I worked a lot for the 1 and 154 as a consultant prior to the standdown and shift. I miss seeing the big birds @ Miramar; I grew up near there.
    – D.E.Wright
    Sep 16, 2011 at 22:53
  • I have been reading the documentation and did create a "Spatial Database Connection." It connects and I can see that there is a DEFAULT dbo version with public access, but the Contents window is blank. I don't see a list of tables or feature datasets as I do when connecting to one of my 9.3 workgroup servers running SQL Express.
    – Bratch
    Sep 17, 2011 at 0:50
  • Ok, you will next need to make sure you are connecting as a user that has the right permissions to view the data. Do you already have data loaded to this DB? You will want to try pushing a small featureclass there to make sure you can write to it properly.
    – D.E.Wright
    Sep 17, 2011 at 1:00
  • 1
    To create the SDE databases we ran the ArcSDE post installation (once for each DB) and everything worked. We were able to copy some feature datasets from another connection and paste them into this connection. From the SQL back end we can see all of the tables that were created. Thanks.
    – Bratch
    Sep 19, 2011 at 21:34

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.