2

I know that QGIS and unmet dependencies seem to be a common theme on this site, but this most recent one is a known issue. Through the standard Ubuntu updates in 14.04, at some point QGIS 2.8.1 has an unmet dependency with libgdal .so.1-1.11.1 and gets autoremoved. The solution on the ubuntu-gis list is to upgrade to the nightly 2.9.x version.

However this is not without its problems: Strange circles have appeared on QGIS map? The circles appear for me in 2.9.x and I can't get them to go away.

There is currently no accepted answer to that question, so I wonder if there is some other way to install this vital package.

5
  • I had the same issue when I tried to install python-gdal last night. I didn't read what was going to be removed; it was qgis, qgis-grass, and qgis-globe. Then I couldn't re-install them (under ubuntugis-unstable), with this unmet dependency being cited as the issue. Overnight, the re-install no longer fails with this issue, and I haven't yet encountered any problems using 2.9.x. Are you using ubuntugis-unstable? May 15, 2015 at 4:35
  • I was using ubuntugis. Trying ubuntugis-unstable now
    – raphael
    May 15, 2015 at 4:37
  • I get a 404 error trying to update after adding the ubuntugis ppa, and same dependency error trying to install from ubuntugis-unstable.
    – raphael
    May 15, 2015 at 4:44
  • The problem is due to two versions of libgdal: libgdal1h (default) and libgdal. The first one is installed with QGIS. If you want R with rgdal and PostGis you need libgdal. You can force to install libgdal to have rgdal and PostGis but your system will be broken without QGIS and uncapable to upgrade. My solution was to have stable Debian 8 in another partition. Everything works well there (However, I have one 15.04 version of Ubuntu because I am waiting for a definitive solution).
    – xunilk
    May 15, 2015 at 9:28
  • 1
    @xunilk I cannot understand what you are suggesting. Please clarify.
    – raphael
    May 17, 2015 at 18:26

1 Answer 1

1

After a bit more searching I found @xunilk's answer on AskUbuntu: https://askubuntu.com/a/618307/334823

I removed the ubuntugis ppa and followed that answer and got 2.8.1 back.

1
  • Sorry, I didn't understand your question. I experienced your unmet dependency with libgdal when I tried to install rgdal and Postgis. It was impossible for me to get a good installation. When I forced that (it is possible) I got a broken system uncapable to upgrade and without QGIS (autoremoved).
    – xunilk
    May 17, 2015 at 19:02

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.