Following this question, I've tried to use interpolation in QGIS to get a sense of the topography of a map based on about 3500 track points with elevation. The elevation ranges between 213 and 353 meters with a 312 meters average.

I then try to use IDW with the following parameters:

It takes a few moment to process and then I get a raster with absolutely no variation. The max is the average value and I've got a min of NaN. Of course, the rendering is all of the same color since there is no variance.

By asking for an ASC file instead of a TIF, I can confirm that it looks like it's creating a grid with the same value (average elevation) all over..

What am I doing wrong?

  • 4
    Just guessing here - your points are from the GPS so I'm guessing they're in WGS84 coordinate system? Try doing a save as to a projected CRS, like the UTM zone for the area, then run the interpolation on the projected points. I'm thinking degrees for horizontal and meters for vertical might be the issue. Failing that, if you haven't followed one, here's a tutorial on the process that might help you figure out the misstep.
    – Chris W
    May 17, 2015 at 20:15
  • 2
    Changing to UTM does indeed gives some results!
    – lpfavreau
    May 19, 2015 at 0:18
  • 1
    If you solved the question, please post an answer in the answer box. Tks. Sep 8, 2016 at 17:53

1 Answer 1


I had the same experience. It turns out that there is something wrong with the Coordinate Reference System (CRS) of the project.

What you need to do is:

  • Right click on the reference points layer (the one you one to interpolate)
  • Then click Layer CRS
  • Then click set project CRS from layer

The IDW interpolation should work fine now.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.