1

I recently upgraded from 10.0 to 10.3 and am having a LOT of crashes when trying to launch the app. I have been using MXD's started in 10.0 but re-saved under 10.3 as well as ones started fresh in 10.3, both seem to experience crashes on launch. I have also tried just launching the app with no document to start a blank MXD and also get crashes on launch. Each time it is at the very end stages of the launching process, application windows have spawned, things seem fine, then right at the end it crashes.

I did find an old python 2.6 folder on my C: drive from 10.0 which I removed to see if that would help as I know 10.3 uses python 2.7, but no change.

It's getting very frustrating as launching the program has become tedious, with it crashing repeatedly, then mysteriously launching just fine, working for a bit, then I try and open another instance and I get crahses on the new instance, or I close the working instance down and try to restart the exact same MXD and I get non-stop crashing.

I am running Windows 7, have updated to the latest updates.

  • Do you have any custom extensions installed? – Kirk Kuykendall May 21 '15 at 20:29
  • I previously had an add-in to fix layer extents installed, but removed it to see if that fixed the crashing, but no change, still crashing and no other add-ins installed. I do have XTools Pro installed, but have updated it to the latext 10.3 compatible version and still crashing. – user25644 May 27 '15 at 22:29
  • Did you ever find a solution to this? I'm having the same exact issue. – user71722 Apr 21 '16 at 13:42
  • This does not provide an answer to the question. Once you have sufficient reputation you will be able to comment on any post; instead, provide answers that don't require clarification from the asker. - From Review – jbchurchill Apr 21 '16 at 14:10
  • @james Have tried renaming normal.mxt and then launching ArcMap again? Creating a new map document template can sometimes fix problems like these. – cl3 May 25 '16 at 17:20
1

No 100% solution, but i did find a trick that seems to improve the crashing on launch.

When I crash on launch over and over I start the task manager and look for two processes: ArcGISCacheMgr.exe and ArcGISConnection.exe, and i force-quit both processes. I believe they are supposed to quit themselves after quitting ArcMap, but I often find they do not, even after waiting for them to quit on their own for several minutes.

Once I have force-quit those two processes and relaunch ArcMap I find it often launches fine and does not crash. Sometimes it still crashes, but often this fix seems to work.

0

I recently had a similar problem

ArcMap crashes on launch. Each time it is at the very end stages of the launching process, application windows have spawned, things seem fine, then right at the end it crashes.

I though it might be helpful to add my solution to the post. In this my case ArcMap 10.3 has been installed and working fine for a year or so and this happened out of the blue. It also wouldn't start at all and crashed every time it was launched.

I tried deleting my normal.mxt and all of the other fixes mentioned in posts I could find (even a clean new install of ArcGIS Desktop) no good. What ended up being the problem was something to do with my dual monitors. I noticed the ArcMap window was spawning on my secondary monitor not my primary as per usual. Once I turned off my secondary monitor and started ArcMap the window spawned on my primary monitor and worked fine. Once I minimized and closed the window ArcMap began to launch normally again. Just to note, I had never had a problem using my secondary monitor with the ArcMap before but usually it would launch on my primary so I noticed that was strange.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.