5

I've been manipulating Geoserver for some time without any problem.

Today,when I start Apache Tomcat , Geoserver doesn't start.

I get this error message :

" FAIL - Application at context path /Geoserver could not be started"

I don't know what seems to be the problem. Please help me with this issue ᐧ

  • that usually happens to me when I add an unsupported with that version jar(plugin) – elasticrash May 22 '15 at 10:49
  • Thanks @elasticrash for you reply. I didn't quite understand what you mean by unsupported, Geoserver was running great for weeks , but today it couldn't start. – ImaneKtb May 22 '15 at 10:54
  • It did happen with me the same a few weeks ago. My problem was the geowebcash reached the allowed limit for the generated tiles and after that the geoserver couldn't set up. I tried to change the limit in one of the config file but no success. I had to delete some of the genereated tiles manually and after that it worked perfectly. – Tamas Kosa May 22 '15 at 11:03
  • @TamasKosa , thank you for the tip. Could you please let me know where in the geoserver folder I need to delete exactly? i'm complete newbie at this .I'd be thankful. – ImaneKtb May 22 '15 at 11:08
  • @ImaneKtb you can find in ../geoserver/gwc/yourlayersfolder – Tamas Kosa May 22 '15 at 11:12
1

@ImaneKtb you can find in ../geoserver/gwc/yourlayersfolder. Just delete one of you "yourlayersfolder". The full path of the geoserver it depend on your type of install (Windows, Linux, Geoserver installer, Boundless installer etc.) It helped to me, but it does'nt mean it will help in your case. The error looks kind of generic error. But anyway, hope it helps.

  • thanks for help . But delecting gwc files didn't solve the issue. Now, I tried this : I replaced the Geoserver folder that couldn't start and generated another one by executing the war .Then I replaced the 'data' repository by the previews one that had all my data . When I run Apache, Geoserver starts, however when I see that all my previews layers aren't active . When I try to republish them . I get this error : "Failed to load attribute list, internal error is: null" – ImaneKtb May 22 '15 at 13:28
  • Is the store enabled? – elasticrash May 22 '15 at 14:15
  • Yes both the workspace and the data store are activated,only when trying to publish the layers I get this error . – ImaneKtb May 22 '15 at 14:19
  • 2
    Are you sure permissions are set correctly on the data folder, such that the tomcat user can create folders. – BradHards Apr 24 '16 at 0:30
0

I also experienced a situation like this.

Apparently everything was "ok" with my Tomcat installation, and I also seemed to place the .war file properly (as I could see its folder being created on the /webapps directory).

What helped me find the answer was to check the Tomcat logs; you can see them in the /tomcat/logs directory (specifically the catalina.out file).

My problem was that the version of Geoserver I was using (2.13.0) requires Java 8 to run, and I was using Java 7. I suggest you check your logs, and also the requirements of your Geoserver version. Changing my configuration to use Java 8 solved the problem and I was able to start and access my webservice successfully.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.