1

This question already has an answer here:

I have converted a GIS shapefile of Botswana from the geographic coordinate system GCS_WGS_1984 to the projected coordinate system Africa_Albers_Equal_Area_Conic to be able to calculate the area of the polygons of the shapefile (and later to calculate buffers etc.). But the scale of the projected shapefile is completely wrong, which skews the area (and distance) calculation. For example, when I use the ruler to calculate the distance between two points, a ~113km distance in reality is measured as a 0,001087 km distance on the data frame, thus about 100 000 times too small...

But when I do the same distance measurement with the ruler when the shapefile is under the geographic coordinate system GCS_WGS_1984, there is no problem.

Does someone have an idea how to fix this problem, and end up with a correct scale when I'm using the projected coordinate system?

marked as duplicate by Chris W, PolyGeo May 26 '15 at 0:17

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

  • What software package are you using? Sounds like ESRI. From what I remember, it's important to make sure your data frame and shapefile both have projections assigned when trying to reproject data. – nagytech May 24 '15 at 12:08
  • Yes, Arcgis 10.2, and my data frame and shapefile have indeed the same assigned projection, that is Africa_Albers_Equal_Area_Conic – Marie May 24 '15 at 13:13
3

just to venture a guess - was the shapefile projected to the new coordinate system or re-defined as a new coordinate system? (i'll assume ArcGIS was used)

it almost sounds like define projection was used, which will not actually modify the geometry of the polygons - it simply tells GIS that the polygons are in a given projection. Thus, if a poly spans from 15 to 30 degrees longitude - and it's redefined to be an albers projection with units of meters - GIS will simply think the polygon spans 15 to 30 meters (which would make any measurements of the poly very small).

instead, the project function should be used, which will create a brand new shapefile with the correct coordinate system. Note - you would need to revert the shapefile back to it's original system (GCS) prior to using project.

  • Yes indeed I used "define projection"... I tried the project function and it worked!! Thank you so much !! and also for your detailed answer :-) – Marie May 25 '15 at 10:45
  • you're very welcome. – fluidmotion May 25 '15 at 16:37

Not the answer you're looking for? Browse other questions tagged or ask your own question.