1

I wonder why there is not any configuration parameter (DEFAULT Keyword) for spatial indexes in Arcsde for postgres. In ArcSDE for Oracle we have S_STORAGE,S_INDEX_SP_FID,S_INDEX_ALL parameter for configuring spatial index table and its indexes.

When I creating a feature class in postgresql, spatial indexes go into the default tablespace. I don't want this behavior. Am I missing anything?

To elaborate on my question, when I create a feature class in database, the sql that gets executed is (gdo is the user and schema owner):

CREATE TABLE gdo.FC1 (
  objectid  integer NOT NULL,
  name2       varchar(20),
  "name"      varchar(20),
  shape       sde.st_geometry
) WITH (
    OIDS = FALSE
  )
  TABLESPACE gdo_bdata;

CREATE INDEX a19_ix1
  ON gdo.FC1
  USING gist 
  (shape);

ArcSDE for postgres, creates spatial tables (FC1), using B_STORAGE (business storage) parameter. But it doens't use any B_INDEX_* parameter for spatial index creation. It seem the user (me!) has no control over spatial index (GIST) creation.

  • ArcGIS (+ArcSDE) : 10.2.1 and 10.3

  • Postgresql: 9.2

  • Geometry Type: ST_Geometry

  • 1
    Please edit your question to contain the version of PostgreSQL in use, the version of ArcGIS in use (plus any patches), and the geometry storage type (ST_GEOMETRY or PG_GEOMETRY). Spatial indexes work differently in PostgreSQL, so there may not be a storage key (which would also mean you could change the storage in a REBUILD request) – Vince May 27 '15 at 18:26
  • Don't you think they could add a parameter (key) for this? – Farid Cheraghi May 27 '15 at 19:02
1

The omission in the dbtune parameters have been acknowledged, by Esri development and are intended to be addressed in the next release. The changes will address the ability to control the placement of the spatial index on the business table, the a table (created by registering the feature class as versioned) and the location of the sde log files.

  • Thanks. But Is there any information on ESRI's own website about this? – Farid Cheraghi May 27 '15 at 20:29

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.