0

I am not sure why this is happening, I am able to stage a Geocode Service, but when I try to upload it to the server it continues to fail. I am able to upload regular MXD Mapping Services. Below is the error that I keep receiving, but there is nothing of note in the server logs. My only guess is that the server is 10.2.2 and I am using ArcGIS Desktop 10.3, but I didn't think that mattered since 10.1

Error

  • Are you trying to publish locators from a file geodatabase? There is a bug at 10.2.1, and I think 10.2.2, where locators from a file geodatabase cannot be published. In my case the work around was to copy them to a regular folder and then publish. – Dowlers May 28 '15 at 22:47
  • @Dowlers, I do not think so, I am just trying to publish the locator from the Streetmaps North America data. I have done it in the past with one try – GravitaZ May 28 '15 at 23:03
  • Oh well, it was just a thought. Can you publish directly instead of staging the service definition? – Dowlers May 28 '15 at 23:14
  • Thanks for the tip though, My Next try is to copy the service definition directly to the server machine and try publishing it. Maybe something is going awry with the remote upload. – GravitaZ May 28 '15 at 23:25
  • @Dowlers it seemed to work when I copied the service definition to the Server machine, then published it using the Server Manager instead of ArcCatalog. I am not quite sure what was going on with the other methods. – GravitaZ May 29 '15 at 19:38
0

his problem just seemed to randomly fix itself. Everything has been working perfectly. Possibly restarting the server instance fixed it.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.