0

I have shapefiles and mxds that were working fine in 10.1. I then downloaded version 10.3 ArcGIS Desktop Advanced. Now when I open the mxd, all of the data links are broken. when I open properties to reset the data source, I get an error: "***Error opening Feature Class". I get the same error on a blank map and adding a shapefile.

I tried to preview the same shapefiles in arcCatalog - I get the same error plus an additional that says "number of shapes does not match number of table records"

Any ideas? My final strategy will be to uninstall 10.3 and go back to the earlier version.

There are some shapefiles that will open in ArcMap, but not very many. I haven't figured out a pattern yet. I can open ALL of the shapefiles fine in QGIS.

I've never had 10.1 on this device - I had to move my license over. I am on a Surface Pro with Windows 8.1 and 64 bit.

I did initially download Pro - and then realized my license didn't cover that, so then downloaded Desktop 10.3. Perhaps something in Pro is interfering? Still, some data works and some does not. Does anyone know if there are any utilities needed to "upgrade" shapefiles to 10.3? Is there a format or support change?

I did a clean uninstall. Installed 10.2.2 instead. Same issues. I tried using Jody Marca's Shapefile fixer without effect. Also went through the entire list of ESRI suggestions: Check Geo, Repair Geo, delete portions of shapefile, etc. I did notice that there is a lock file from my old computer on some of the unopenable shapefiles. Continuing to hunt.

  • Did you fully uninstall ArcGis 10.1 prior to installing the new version? I assume there's nothing wrong with the shapefiles.. do you have QGIS/Global Mapper/MapInfo to verify the files aren't broken (ogrinfo should tell you). there was a utility in a previous version (I think 9 to 9.3) that fully uninstalled ArcGis, search Esri/install media for the uninstall utility.. it sounds like you've got a mismatched dll in your GAC. Can you try create a new shapefile in Catalog and see if that has the same problem. – Michael Stimson May 29 '15 at 4:23
  • 1
    I agree with @michael-miles-stimson -- opening a blank map and getting that error sound like a corrupted/mis-configured install. I would scrub ArcGIS off your system and try to start fresh. – Mintx May 29 '15 at 22:02
  • 3
    Shapefiles don't have version dependencies. And if you can open an mxd but not add a shapefile, then it would appear the shapefiles are the problem, not the mxd or install (especially if you can open some shapefiles - might want to grab a few from the internet/another source and test those). You say you never had 10.1 on that device, but you used 10.1 previously. That suggests to me you also copied/moved the shapefiles between devices or are accessing over a network. Perhaps they have become corrupted? Can you still open them on the original device, if that's still available? – Chris W May 30 '15 at 8:31
  • 1
    It appears you created a new login to update your question. Anyone can suggest edits, but they have to be reviewed. Since it's somewhat clear you're the OP, so far I at least approved it. Had you signed in with your original account, the change would be immediate. You might want to merge your two accounts. FYI, you can manually delete lock files - if they came from the old machine they're not doing anything anymore except possibly messing things up. However they could indicate the files weren't closed/saved properly and corrupted. – Chris W May 31 '15 at 21:24
  • Please merge your two accounts ASAP. – PolyGeo May 31 '15 at 21:29
1

I agree with Chris W.

Never had problems with putting "older" shapes to a newer ArcGIS version. The fact that "number of shapes does not match number of table records" and that you noticed "that there is a lock file" shows that the files were not closed completely.

I got the error "number of shapes does not match number of table records" (sometimes) for example if I deleted features while editing shapes in ArcGIS 10.0 and 10.1 (only the geometry was deleted but not the line in the attribute table) or the system crashed unexpected while editing. Among other things, therefore I only use gdb.

That there is still a lock file is a indication that the mxd and/ or the shapes were not closed completely. For example you start copying files before the mxd was completely closed (if you close an mxd and use Ctrl + Alt + Del you will see that ArcMap is still running under processes for a while; some addins also prevent ArcMap ends like it should). The lock file disapears only after the mxd was closed completely.

You said, that you tried some "repair" tools for shape: Be aware with it. Sometimes they work like you hope, sometimes they did not work and sometimes they work wrong: I had a big FC, were the shape was "repaired" but the attributes where wrong. To line 1.500 all features were correct but feature 1.501 had the attribute of feature 1.502, feature 1.502 had the attribute of feature 1.503 an so on.

If you have a "original" record - possibly a backup - use a copy of it. The more you try with your faulty records, the more mistakes can happen.

protected by Community Sep 17 '15 at 17:11

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.