1

I'm trying to make a pretty shaded relief map using the technique described here.

I've done this process several times in the past without any problems but today am perplexed about what is going on. I have a DEM (IMG format) that I've set the color ramp on. The next step is to export the DEM to an RGB image so that it can be pan-sharpened with the hillshade. However, when I run the export tool (right click on the layer, Data, then Export Data...) the resulting layer is not even close to the color scheme I want. I've made sure that I've checked the "Use Renderer" and "Force RGB" boxes as described in the article.

Here is my example. The color scheme I want is on the left, what I'm getting from the export is on the right: Colors I want and the colors I get

I've tried to adjust the symbology on the exported raster to get back to what I wanted but I don't know enough about what is going on to get it set right.

What am I missing here? How do I get my exported image to match the colors I choose in the DEM?

Using ArcGIS 10.2.1, Windows 7.

-- EDIT -- Here is another screenshot of the whole DEM and the whole exported raster. This one using a different color ramp (Elevation 1) on the left and the exported raster on the right: enter image description here

7
  • Is the left what it looks like on screen and the right what is actually being exported? What stretch are you using.. perhaps it's re-stretching the raster on export; try min-max and check the box 'edit value' to make the stretch static. Commented Jun 4, 2015 at 21:07
  • The left is what's on the screen when I run the export, the right is what's on the screen after I add the exported layer to the data frame. I just tried with it set to Min-Max and the edit values box checked - same result.
    – Kevin
    Commented Jun 4, 2015 at 21:10
  • 1
    Can you include a screen shot of your parameters and the re-added raster layer symbology tab. Perhaps it's got the band order the wrong way around when it's re-added or some really unrealistic stretch/gamma on the bands. Have you viewed the image in paint/photoshop/Gimp? Commented Jun 4, 2015 at 21:51
  • 1
    It's an indication that ArcMap isn't stretching it properly. Change your stretch to None and ensure bands are 1,2 and 3. There must be something in your image aux files that's a bit funny... perhaps deleting them could fix it (just move to another folder in case they're needed). It's looking like it is a duplicate @ChrisW. Commented Jun 4, 2015 at 22:03
  • 1
    @MichaelMiles-Stimson I think your first comment mostly had it, but it's re-stretched on import, not export. See possible duplicate. Kevin, there's a comment on the blog post linked in the question with a response from the author that addresses this. Search for stretch in the comments and you should find it pretty quickly.
    – Chris W
    Commented Jun 4, 2015 at 22:12

0