I have tried to convert a raster to points using this syntax (r.to.vect):

r.to.vect input=g_kelowna_merged@kelowna_mapset output=g_kelowna_points feature=point

I have tried using the GRASS interface in QGIS and also directly in GRASS GUI 6.4.3 and 6.4.4.

What happens is that the points get created and show in the Map name box but there is nothing in the Layer box and QGIS says "No layers available in this map". Looks like I created a map, not a layer. Any suggestions for getting those points?

3 Answers 3


I'm not sure, but maybe youneed to define a region from your input raster. I had the same problem and the cause was the region


I am not sure why your r.to.vect is not working as expected in QGIS. Maybe your raster is too big? When I am running it from processing toolbox and choose Save to file it creates as expected point shapefile and loads it into map under temporary layer name.

For big rasters you can try convert raster into points (x,y,z) in QGIS by using Raster / Conversion / Translate and choose output format as ASCII grided XYZ which generates text file of x,y,z. That is definitely way more robust and faster method. It is very handy when you need to do something with XYZ in non-GIS software. You can easily load it into QGIS as points through Add Delimited Text Layer.

(In GRASS also r.out.xyz)


I think the problem was that the process took so long to run that I thought it had quit. This time I cut the raster in half and then created a smaller raster using r.thin and let it run. Still it produced 600,000 points. I'll try it again, using a raster that is even more thinned.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.