2

I am super new to QGIS so I may be doing something really dumb, but it doesn't seem to work to create a heatmap in QGIS Desktop 2.8.2 (just downloaded this yesterday so I think it is the most current stable release). I load my points in from a SQL server geometry column, then click Raster > Heatmap > Heatmap. Then I change none of the defaults on the "Heatmap Plugin" dialog except where to save the raster and hit "OK". The resulting raster looks like it uses very few of the points in the "Input point layer". Is there any way to get this to use all the point when constructing the heatmap?

Here are some pictures showing this process:

After loading all my points:

After loading all my points

Heatmap Dialog Box:

Heatmap Dialog Box

After hitting OK on the Heatmap dialog box above and it renders (a progress bar dialog that isn't in the picture pops up for a minute after hitting "OK"):

After hitting OK on the Heatmap dialog box above...after it renders

This is what the rendered tiff looks like when I open it in Photoshop:

This is what the rendered tiff looks like when I open it in Photoshop

  • The first thing that stands out to me is you have the tool set to use a search radius of 20k meters, but your project is using WGS84 (EPSG 4326 in the lower right corner) for a coordinate system which has degrees for units. You may want to try projecting your data (I would say UTM, but it looks like your data may cover more area than a single UTM zone, so maybe north america albers equal area conic). Or changing the radius units from meters to map units. Or using underdark's alternative suggestion. – Chris W Jun 6 '15 at 18:46
  • I would suggest you to file an issue using QGIS' issue tracker (hub.qgis.org) and to attach the data to your submission. That way, a developer can have a look at why only a subset of your points are taken into account when creating the TIFF heatmap. – nirvn Jun 7 '15 at 10:56
  • @ChrisW Thank you for your comment. Now I can no longer reproduce the error, the heatmap generation just generates an empty raster every time. I tried using map units (tried 1 map unit as the radius) and it did work with a more limited dataset of 100 points I was testing with. – David Jun 10 '15 at 20:49
  • @nirvn thank you for helping also. I will submit an issue but it will be a little different now that I cannot reproduce the subset issue and that I understand a more limited set of cases where the heatmap is failing with this data. – David Jun 10 '15 at 20:59
  • I believe this subset issue was due to bad layer data. I didn't have a primary key on my table so I loaded the data in a kind of weird way (loaded version of table that only had 100 data points in it then add the rest of the data to the table and hit the "refresh" button in QGIS). – David Jun 10 '15 at 21:03
3

If you only want to visualize the density, I recommend using the new Heatmap renderer as shown in the following screenshot:

enter image description here

  • Thank you! Using layer styles does give me a lot of what I want but I would love to get the raster generation working (so I can do cool things like make 3D maps using the raster). – David Jun 10 '15 at 20:31

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.