1

Our company just switched over to a new server setup and at the same time moved from ArcMap 10.1 to 10.2. Everything seems to be working ok but when I am working with feature classes I sporadically get this error (in this case alt2zon is my feature class)

One or more layers failed to draw: alt2zon: General function failure

It doesn't seem to be tied to any one action I am performing, although it seems to occur when I am running larger datasets. If I remove the layer and re-add it still doesn't work. To solve the problem I have to save the MXD, close it, reopen, and the issue is resolved.

Any ideas as to what is happening?

  • 1
    What version(s) are the mxds in and what version were they originally built in? Aka 10.2 or 10.1 or? Have you tried running MXD Doctor? – mkennedy Jun 9 '15 at 21:07
  • What data source is alt2zon? Shapefile, SDE, Geodatabase (file or personal). Is it likely that other users are accessing the data at the same time? It could be a locking situation or network hiccup... does this occur in new map documents or just existing ones? Is the layer added from the data source or from a layer (.lyr) file? – Michael Stimson Jun 9 '15 at 22:52
  • Have you checked the integrity of the data? Maybe it's corrupted or damaged. – brentiemapper Jun 10 '15 at 0:40
2

I've been using 10.2.2 for about 4 months (Windows 8.1) and the mxd that I'm using was built with that version. I got this error message yesterday and again today (clean opening of mxd); no amount of saves, etc., gets rid of the message. No one else is sharing the File GDB that the data is coming from (no one else even knows it exists); there are no locks in the GDB directory. At ALL TIMES, ArcCatalog has absolutely NO PROBLEM displaying the features and attributes. My solution was to copy the File GDB from its network location to my local C: drive and all problems vanished (well, so far they have). That might not be a possibility for you. Note that all my other data is coming from shapefiles or Enterprise (SDE) GDBs OVER THE NETWORK and none of them have had any problems. Also note that my ArcMap is fully patched. Also note that this File GDB is MY DEFAULT workspace and has had absolutely no problems until yesterday. Also note that if I start a brand new mxd there are no problems using the FGDB on the network (the existing mxd with problems does have a lot of data loaded). Also note that after checking these in the new mxd, I went back to the original mxd and used them with NO PROBLEM. I have no idea what all of this means.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.