1

My environment:

Windows 7 Professional: Service Pack 1 64-Bit

QGIS: QGIS-Version: 2.8.2-Wien 32-Bit

Microsoft Office 2010 Professional: 32-bit

I want to connect an ESRI Personal Geodatabase (*.mdb) with the "Add Vectorlayer" feature in QGIS QGIS vector layer

The problem is with the Access Jet driver.

My Questions:

Has anybody successfully connected to an ESRI Personal Geodatabase in QGIS 2.8.2?

  • use Datei (personal geodatabase is a file .mdb though file geodatabase is database) – Mapperz Jun 16 '15 at 16:21
  • 1
    What error are you getting and how are you trying to connect using Jet? – Branco Jun 16 '15 at 17:53
  • Is it a geodatabase though? Just because it's a .mdb (Microsoft Jet (Access) database) doesn't necessarily mean it's a geodatabase. Perhaps your Jet error is 'can't find the table gdb_####'. That aside you need to set it up in ODBC first see northrivergeographic.com/qgis-accessing-personal-geodatabase about setting up ODBC for JET – Michael Stimson Jun 16 '15 at 21:55
  • This question Has anybody successfully connected to an ESRI Personal Geodatabase in QGIS 2.8.2? is a duplicate of gis.stackexchange.com/questions/129514/… – nmtoken Jun 17 '15 at 9:27
2

Thank you for your inputs.

My source is an ESRI Personal Geodatabase (*.mdb). I can open the source in MS Access. The table GDB_ColumInfo, GDB_GeoColumns, GDB_ITEMRELATIONSHIPS, etc. and many Geometry-Table are there.

I have already created a successful connection on File (Datei) and File Type ESRI-Personal GeoDatabase (*.mdb). It runs, but it is a "READ ONLY" Connection.

But now, I want a Connection on Database (Datenbank) with the hope this will be a "READ-WRITE" Connection.

I read a lot in the forum, I must first install the correct Access Jet Driver. 32bit or 64 bit under MS Windows System Settings enter image description here

I will now following the way from Michael Miles Stimson with northrivergeographic.com/qgis-accessing-personal-geodatabase

  • Please ask another question, rather than posting a follow up as an answer. – John Powell Jun 17 '15 at 7:25

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.