1

The basic issue is that I have shapefiles saved in WGS84/Pseudo Mercator (EPSG: 3857) and some DEM data saved in NAD83/UTM Zone 10N (ESPG: 26910), but can't get them to line up.

I'm using QGIS and have my file CRS set to WGS84 (3857) with on-the-fly projections enabled. My global settings allow on-the-fly to automatically be applied to any new layers added that aren't in the drawing CRS.

The DEM files that I'm having trouble with are from the National Elevation Dataset (NED) and were obtained through the NRCS Geospatial Data Gateway. I've tried to change the DEM layer CRS in the layer properties. I've also tried to change the CRS by right-clicking the layer and choosing "Set Layer CRS" and I've tried to "save as..." and alter the CRS for a new layer file. None of those have worked.

Then I tried to use GDALWARP to reproject the DEM from NAD83 to WGS86, but the DEM just ends up in exactly the same spot.

Trying to change the CRS of the drawing and the shapefiles to meet the DEM is similarly counter productive. They are outside the bounds of the NAD83 UTM Zone 10N, so they just disappear.

I'm pretty new to QGIS and GIS in general, so it's likely that I'm making a real rookie mistake here. I'm using QGIS 2.8.1 Wien on a Windows 8 computer if that helps.

  • Your exact syntax could help. QGIS has a problem with exporting to 'match canvas' in that it doesn't.. best to use 'as specified' to export to a new spatial reference. Are all your coordinate systems set/defined or are some assumed? – Michael Stimson Jun 17 '15 at 0:46
  • How much offset in meters do you have between both layers? – AndreJ Jun 17 '15 at 11:55
  • Andre, there are two sets of DEM files. A limited set of 3m offsets and another set of 10m offsets that provides full coverage of the county that we're dealing with. – bberry Jun 18 '15 at 21:08
  • Michael, the NRCS DEM files are defined by the metadata as NAD83. The shapefiles in the drawing were added by my boss, so I'm assuming that they are 3857, but I don't know the source. I'll have to take a look at the file again on Monday, when I return to the office. I'll pull the re-projection syntax from the layers on Monday as well. Thanks for the help. – bberry Jun 18 '15 at 21:19
1

Thanks for all of the suggestions.

Over the weekend my boss re-imported the shapefiles that were giving me trouble. QGIS assigned them custom "user:100000, *generated CRS" to match the file CRS (EPSG: 3857).

It looks like the shapefiles were arbitrarily assigned to WGS84 by one of us at some point last week.

So I suppose the lesson learned here is: know the location and original CRS of vector and raster data that is imported into a drawing. If there are issues with the projections then the troublesome layers can always be re-imported with on-the-fly enabled.

0

I have read the history of this projection somewhere. Some software needs to see certain codes. You might try redefining the projection to EPSG:3785 or EPSG:900913. Same everything else I think.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.