1

I'm running
QGIS version 2.8.1-Wien QGIS code revision
Compiled against Qt 4.8.6 Running against Qt 4.8.6
Compiled against GDAL/OGR 1.11.2 Running against GDAL/OGR 1.11.2
Compiled against GEOS 3.4.2-CAPI-1.8.2 Running against GEOS 3.4.2-CAPI-1.8.2 r3921
PostgreSQL Client Version 9.3.5 SpatiaLite Version 4.2.0
QWT Version 6.0.2 PROJ.4 Version 480
QScintilla2 Version 2.8.4

on OSX 10.10.3 and the QGIS has of late become very slow. I don't mean functions are slow I mean simply clicking around on the GUI. I know QT4 sucks but it never used to be this bad. Is anyone else experiencing this and, more to the point does anybody have a solution?

  • 1
    have you compiled your own version or do you use a Mac OS X version (KyngChaos, Homebrew,...) – gene Jun 17 '15 at 14:58
  • Its the KyngChaos version. I opened the same project in a VirtualMachine Lubuntu installation and it was fine, but I took the opportunity to remove some large rasters from the project, rasters that weren't visible but still listed. Upon returning to the OSX version everything was back to normal. It seems odd to me that the OSX version fills the assigned memory with data not being used, metadata alone would be sufficient. Of course this could be another "feature" of 10.10 on a Mac with HDD rather than SSD (see previous rants distributed across the web). – mercergeoinfo Jun 18 '15 at 8:23

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.