2

I created a new vector layer in QGIS, saving as I went along and then I saved the project and logged out. When I went back into the project, I wanted to add some more features to the same layer, so selected the toggle editing icon and highlighted the vector layer. However, not all the options are displaying for me - I can select 'move features' or 'node tool' but can't select the 'add feature' option, for instance.

I took a look at this question which seems to be a similar issue: After re-open of old project file, several layer selections no longer available

As suggested, I tried switching on and off the layers and exiting QGIS again, but so far I can't resolve the issue.

I am relatively new to QGIS.

closed as off-topic by underdark Jun 17 '15 at 19:16

This question appears to be off-topic. The users who voted to close gave this specific reason:

  • "Questions describing a problem that can't be reproduced and seemingly went away on its own (or went away when a typo was fixed) are off-topic as they are unlikely to help future readers." – underdark
If this question can be reworded to fit the rules in the help center, please edit the question.

  • 1
    Could you edit the layer outside your project? I.e. load the layer itself into QGIS and see if you can add features. – Joseph Jun 17 '15 at 13:03
  • Thanks, Joseph - I tried that. I'm now worried that the file might be corrupt somehow. I just went into the layer folder and I can now see that one of the file extensions looks a bit strange - it is formatted [filename]_packed.dbf The other extensions are fine .prj, .qpj, .shp and .shx. Has anyone come across this before, and is there a way to rectify it? – rhm Jun 17 '15 at 13:11
  • 1
    I think the following link covers this: How to avoid creating corrupt Shapefiles during Editing?. Hopefully you have made backups =) – Joseph Jun 17 '15 at 13:14
  • 1
    OK, would you believe, I managed to resolve this simply by deleting '_packed' from the file name. This was among the suggestions in the link you sent me, Joseph, so thanks for that - much appreciated! Good point re: back-ups, I had made one but it also included the corrupt user name, so I will go and back this up straight away. – rhm Jun 17 '15 at 13:27
  • 1
    Haha glad you got it resolved! And your most welcome buddy! You should post what you did as an answer, the suggestion you followed in the link was posted as a comment and the user who posted it hasn't been active for a while so I think it might be best for you to post it which could help others with similar problems :) – Joseph Jun 17 '15 at 13:38
1

It turns out that one of the files had got corrupted. When I went into the layer folder, one of the file extensions was ending in [filename]_packed.dbf rather than just [filename].dbf

I managed to resolve this simply by deleting '_packed' from the file name.

Not the answer you're looking for? Browse other questions tagged or ask your own question.