Fairly new to GIS here, especially new to working with enterprise geodatabases. I am attempting to publish a service from arcmap to arcgis server using a version of the DEFAULT. I am using connection files from two separate databases in SQLserver 2008 (db1 and db2). Let me walk you through my processes:

  • add database connection using sde database authentication to db1
  • import data, manage privileges, register as versioned, add Global IDs
  • geodatabase administration > create new version from DEFAULT (named v1)
  • add new database connection using my windows authentication to db1
  • change geodatabase connection properties > select v1 from Transactional version
  • add data to arcmap from v1 version

Register database When I register my geodatabase with ArcGIS Server, I import the connection file to db1 as the publisher database connection, and the connection file to db2 as the Server database connection, leaving the create geodata service option unchecked. The database registers and validates properly on arcgis server manager. The reason I have the separate server database connection is so I can replicate my data and synchronize my edits between my v1 version and arcgis online.

Next: - right click my windows authenticated geodatabase > share as geodata service (so i can publish it in a specific folder) - go through the publishing steps but when I click analyze, I keep getting the error 00133 Geodatabase is not registered with the server.

HOWEVER, when I follow these same steps using the DEFAULT version, it publishes fine. Arc does not seem to produce a separate connection file for the versions I create, so how do I get my service to recognize my registered geodatabase when publishing a version???

The same thing happens when I publish a map service (with feature access enabled) using v1 versus DEFAULT, except I get the error 00090 Feature service requires a registered database.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.