2

I've tried setting QGIS to on the fly, changing the layer settings, nothing.

I'm at a lost cause. Although I am not a GIS professional.

rancosshapefile

http://www.ecaidata.org/dataset/spanish-and-mexican-land-grants-in-california/resource/9c7a68d8-a73e-40bf-8b39-a1f041735794?inner_span=True

7

The linked kml file seems to contain valid degree coordiantes, but fails to open in QGIS.

If you follow the source given in your link to http://www.ecaidata.org/dataset/spanish-and-mexican-land-grants-in-california, you can get a shapefile which misses its prj file.

With some kind of educated guess, you will find that NAD27 / California Albers EPSG:3309 fits best:

enter image description here

From that point, you can save the layer to another shapefile with EPSG:4326 WGS84 or any CRS you need.

  • Seems to fit well with its related data set spanish-and-mexican-land-grants-in-california – nmtoken Jun 18 '15 at 16:39
  • Thank you AndreJ! Everything worked! I got stuck on importing the KML into QGIS as it was failing. I'll have to take a GIS course in identifying CRSs. – wayne-m Jun 18 '15 at 23:37
2

With an unknown coordinate system you need to use trial and error... but in this case NAD 27 datum would probably fit the best. You can compare it with the kml file!

In general, the normal way for a transformation would be:

  1. open the shapefile
  2. it will open the "Coordinate Reference System Selector". Select the coordinate system (eg. EPSG 3309) and click ok
  3. change the project properties and enable the "on the fly" transformation to WGS84 (eg. EPSG 4326)
  4. right click on the file and save as shape choosing the wanted coordinate system.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.