5

I am just learning ArcGIS 10.2 and it was working well until I tried to use the Export to a Geodatabase (single) option for a dbs table I made. Since then, it seems I now get the same Script Error for import/export functions. However, I just tried to export to Geodatabase (multiple) and error did not pop up. I spoke with tech support and they could not help me so far. I really do not know much about GIS so it is hard for me to fix this problem and cannot proceed with some things.

  • Are you doing this through the GUI or by script. Is the exact script error "script error invalid pointer"? – artwork21 Jun 18 '15 at 19:35
  • 1
    There should be more to it than that... are you using 64bit background processing? That can give funny errors like this, perhaps turn it off (more about it here resources.arcgis.com/en/help/main/10.1/index.html#/…). It is also possible that the error is 'in the past' so consider clearing your geoprocessing history (more here gis.stackexchange.com/questions/131405/…) – Michael Stimson Jun 18 '15 at 22:37
  • I have done it through ArcMap and ArcCatalog. Both ways it does it. That is the actual message. Title is Script Error, then says Line 63 then Char 4 then Error: Invalid Pointer then next line says Code 0 – LynnR Jun 18 '15 at 22:39
9

I just solved this problem. What you need to do is the following: In Windows go to: Control Panel -> Programs -> Uninstall a program.

Then right click on "ArcGIS for Desktop" -> Select "Uninstall/change".

The ArcGIS Setup dialog will pop up. Chose the "Repair" option.

After finishing the Repair procedures the ArcGIS will be working properly!

0

I resolved this error by repairing the data interop. installation. I also have background processing turned off.

Not the answer you're looking for? Browse other questions tagged or ask your own question.