0

I'm running ArcGIS 10.3 in a Windows 8.1 VM (using VMWare Player). I cannot rename file geodatabases in ArcCatalog. I make sure everything else is closed except for ArcCatalog, I create a New File Geodatabase, but when I try to name it anything else, it gives me the standard "General Function Failure".

I thought the problem was with the data being stored on a partition on my host which I access through a Windows mapped drive, but I've always been able to create/rename/delete folders, shapefiles, and everything else as normal, except for file geodatabases. I have full admin rights on my computer.

This led me to the conclusion that it has to do with the VM locking the gdb as soon as I create it, thereby preventing me from renaming it. However, even if I restart the VM, immediately open ArcCatalog and try to rename it, it still gives the same error.

enter image description here

I've tried renaming older file gdbs as well, with the same result. I've had this problem since running 10.2 on Windows 8. It's quite frustrating to have my neatly organised project folders filled with "New File Geodatabase.gdb", "New File Geodatabase_1.gdb" etc.

I can even rename feature classes and other objects within the file geodatabase, just not the actual file geodatabase. The question is: why cannot I rename file geodatabases in ArcGIS inside a Windows 8.1 VM using VMWare Player* on Windows 7?

*When I used this same VM for a time in VirtualBox, I did not have this issue.

  • I'm confused: gdb are actually stored in the host filesysem and not in the VM filesystem? Also it might help you to identify what keeps the gdb locked: serverfault.com/questions/1966/… – nickves Jun 22 '15 at 10:34
  • If using Windows 8.1 Pro then enable Visualization at the bios level then use Hyper V this will work for renaming geodatabases without the lock. – Mapperz Jun 22 '15 at 14:37
  • @nickves Yes, the data (file gdbs, shapefiles etc) are stored on the host, accessed through the vm via a mapped drive (not VMWare Shared Folders). I know I used the term "locked" but because of what I said next (restarting the VM does not help, and I cannot rename any file gdbs at all, even old ones), this leads me to believe that it is not a locking issue. – Cindy Jayakumar Jun 29 '15 at 4:51
  • 1
    @StephenLead I had to move to using VMs a long time ago because the company's IT department would consistently mess with the machines and force updates onto them without testing it for GIS users. This lead to corrupted databases, messed up ArcGIS installs etc. Using a VM allowed me a clean environment in which to work. Fortunately I am no longer working there. – Cindy Jayakumar Mar 16 '16 at 6:53
  • 1
    "You've messed up my ArcCatalog for the last time - I quit!" – Stephen Lead Mar 16 '16 at 23:13

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.