1

What I am trying to do: Add a vector layer from an remote Oracle database.

Platform: Linux Red hat 7 Database: Oracle 11g Connectivity via unixODBC Oracle

Description: I tried to add a vector layer using ODBC connectivity to an Oracle database on QGIS 2.8.2.

Add vector Layer
Choose Database
Type ODBC
Click New

I filled the form as:

Type ODBC
Name: myODBCConnection
Host: ssfdata
Database: CAAR
Port: 1521
Username: USER
Password: PASS

When I clicked Test Connection I got:

Connection failed – Check settings and try again

Extended error information:
Unable to initialize ODBC connection to DSN for USER/PASS <at> CAAR,
[unixODBC][Driver Manager] Datasource name not found, and no default driver specified

I opened a terminal window and I typed:

Isql –v caarODBC

I was able to connect to my database

+------------------------+
| Connected              |
|                        |
| sql –statement         |
| help [tablename]       |
| quit                   |
+------------------------+

SQL>

So the unixODBC driver works for the database but QGIS is not able to access via ODBC. Is any special settings related qgis to make ODBC working?

  • Yes I did and they do not apply. The link indicated is about QGIS on Winodows, As I mentioned in my question I have QGIS on Linux and Oracle connectivity isn't supported. – Marian Jun 26 '15 at 2:27
  • You didn't say Linux. If oracle isn't supported on the Linux (or at least your flavor of Linux) build of QGIS then you wont have much luck irrespective of whether or not another program can access it. I know very little about Linux, Mac or other specialized platforms so can offer very little insight. – Michael Stimson Jun 26 '15 at 2:37
  • I am sorry I mentioned indirectly when I said that unixODBC works. Also the error mention unixODBC which related to Linux not Windows. I will clarify the question. – Marian Jun 26 '15 at 2:46

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.