1

I'm new to GIS and OSM. I've successfully installed OSM locally and now I want to add Nominatim to the mix. I've been following the installation instructions exactly from here: http://wiki.openstreetmap.org/wiki/Nominatim/Installation.

I run into an error when I try to import and index the osm data. The command the guide uses to do this goes as follows:

   sudo ./utils/setup.php --osm-file <your planet file> --all [--osm2pgsql-cache 18000] 2>&1 | tee setup.log

I get a permissions error that I'm not sure how to fix and also it doesn't seem to like the cache specification. This is the error:

    tee: setup.log: Permission Denied
    setup.php: Unknown option '18000]'
1

Remove the [] around --osm2pgsql-cache 18000

Drop the "| tee setup.log" part. (It just pipes the output to a file. And check your permissions)

Like this:

sudo ./utils/setup.php --osm-file isle-of-man-latest.osm.pbf --all --osm2pgsql-cache 18000

Always a good idea to test with a small file like this one: http://download.geofabrik.de/europe/isle-of-man-latest.osm.pbf

  • I actually ended up getting it by not using the cache option entirely, and I fixed my permissions successfully. Thank you for getting back to me, hope your answer helps someone else. – btald1331 Jun 26 '15 at 20:18
  • Better use --osm2pgsql-cache on big osm files. Of course it has to fit your servers memory size – mhoegh Jun 26 '15 at 20:52
1

Options in [] are optional. You can specify them but you don't have to. If you decide to use them then always strip the [], i.e. just pass --osm2pgsql-cache 18000 instead of [--osm2pgsql-cache 18000].

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.