1

I am newbie in GeoJSON file. I am having difficulty to load my GeoJSON file on geojson.io. Here is my GeoJSON file:

https://gist.github.com/anonymous/0abb8f926977d577b52d.

The source file is from:

http://data.gov.sg/common/search.aspx?cs=1&q=Region+Census2010&a=AVA,HPB,IDA,IPOS,IE,MINDEF,SCDF,SPF,NHB,PUB,SLA,SSC,STB,WDA,URA&da=CPF,CAAS,EDB,EMA,HSA,IRAS,LTA,MPA,MCCY,MOE,SING,MFA,MOH,ICA,SPS,MSF,DOS,MOT,MAS,NYP,NAC,NLB,NPAR,RP,SP,SPIB&c=12,03,02,07,09,04,08,05&dc=01,10,06,11&f=SHP&df=CSV,KML,PGDB,TXT,OTHERS,XLS,XML&page=1

named RegionalCensus2010.

It is a shapefile. I convert the shapefile to GeoJSON using QGIS. I don't have any issue when I am using GeoJSON file from other resources like US government file, but somehow I just can't load my GeoJSON file. I have checked the structure of the file which seems to be correct but I am not sure why I can't load map layer on geojson.io.

  • 1
    welcome to GIS.SE - it will help others to answer your question if you add some more information to it, such as what is going wrong, what you expected it to do, where you got the data from etc. – Ian Turton Jun 29 '15 at 10:16
  • 1
    The coordinate values don't make sense to me. They're not latitude/longitude and if they're EPSG:3857, they're offshore Africa, near 0 lat, 0 lon. They're also too small for UTM/GK or State Plane. – mkennedy Jun 29 '15 at 16:49
2

Your data seems to be in a CRS which is not WGS84 (i.e. EPSG:4326). Thus, it can not be properly displayed by github gists nor on geojson.io.

Try to re-export the original shapefile from QGIS to geojson , and choose WGS84 EPSG:4326 in the CRS field of the dialog that opens when you right-click the layer in QGIS and choose "save as.."

| improve this answer | |
0

Initially, I thought it's fine since I can see the shape of the map on QGIS and MapShaper but not geojson.io. But after I tried out the CRS options one by one on GIS. I just figured out I am using the wrong CRS. Nevertheless, thanks for the quick reply.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.