2

I have a layer that is classified using graduated colors. I have set it to a manual classification with 7 levels.

enter image description here

My 1st value of 0 is not needed anymore. How do I remove the 1st level of classification. So that my manualy classification starts at 0.000001 -1000000.000000? So that it looks something like....

enter image description here

I have tried to change my break values to start at 0.000001. But the scale still starts at 0.000000.

enter image description here

enter image description here

I have also tried to used the data exclusion to exclude NULLS and 0, and I am having the same issue, the value 0.000000 still remains.

Also, when right clicking the first level 0.000000 and selecting remove classes, the next level changes to 0.000000 - 10000000.000000..... which I do not want I want. I want the value 0.000000 to be excluded.

enter image description here

Any thoughts on how to exclude the 0.000000 value and have my scale start at 0.000001?

  • In your first image, where you have 0.00000, can't you right click on the symbol and remove class? – Hornbydd Jun 29 '15 at 15:58
  • @Hornbydd, When right clicking the first value 0.000000 and selecting remove classes. Then next level, 0.000001-1000000 changes to 0.000000-1000000. – a1234 Jun 29 '15 at 16:01
  • Definition query may help you. – GIS Data Butcher Jul 1 '15 at 14:17
  • @GISDataButcher Yes, a definition query worked. Thanks! – a1234 Jul 1 '15 at 20:43
  • i have the opposite problem, that i want it to show the zero value on its own but it won't and continues to show it like so:- ![enter image description here](i.stack.imgur.com/d2IsG.png) – elle Jun 3 at 6:20
3

I suggest to perform a definition query on the layer. The expression will be something like this:

[<<attribute name that contains the values>>] > 0

This will exclude all records with null/zero values in the layer and also in the legend.

0

I was just playing around with this and it seems that when you use data exclusion, it excludes the data (in this case 0), but still lists it in the range and label columns. My suggestions would be to manually change the label column to read what you want it to read (click on the label text within the symbology tab). You can double check that the 0 data really is not shown by adding the layer again and symbolizing this to just show the 0 data and then visually confirm (spot-check) that its indeed on shown in the original layer. I hope this helps a little bit.

0

I experienced a similar problem and solved it by Definition Query: Perform a definition query on the layer by right-clicking it from the TOC, go to Properties, choose Definition Query, Query Builder, select the labelling field and define it xxxx > 0. Do the classification again.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.