0

I'm new to GIS and tile servers. I've installed TinyOWS pretty successfully except for what looks like to be some dependency issues. I have installed PostGIS and also PostgreSQL. PostGIS is supposed to come with raster and topology support, so I assume it is already installed but not enabled. Anyway I can't find any good online resources for this so I need some help.

Here is my error:

NOTICE:  Function postgis_gdal_version() not found.  Is raster support enabled     and rtpostgis.sql installed?
NOTICE:  Function postgis_topology_scripts_installed() not found. Is topology support enabled and topology.sql installed?
NOTICE:  Function postgis_raster_scripts_installed() not found. Is raster support enabled and rtpostgis.sql installed?
NOTICE:  Function postgis_raster_lib_version() not found. Is raster support enabled and rtpostgis.sql installed?

Update: I've tried creating an extension to these like as follows:

CREATE EXTENSION postgis;

Then I get the following:

ERROR: PostGIS is already installed in schema 'public', uninstall first
  • What version of PostGIS and PostgreSQL are you using? – HeikkiVesanto Jul 1 '15 at 14:20
  • The version is 2.1. Sorry, probably should've included that. – btald1331 Jul 1 '15 at 14:28
  • PostgreSQL is version 9.3 – btald1331 Jul 1 '15 at 14:47
1

The topology extension has to be CREATEd separately:

CREATE EXTENSION postgis_topology;

As to why also your raster functions fail: could you verify you are trying to use a version of PostGIS with raster support compiled in? (see http://www.postgis.net/docs/RT_FAQ.html#idp61635392)

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.