2

Can anyone please explain to me in step by step instructions how to install rasterio with Python 2.7 on Windows. I have Windows 8 and have tried information on Link

I have installed all the dependencies mentioned and when I try to run the following command on command prompt:

$ rasterio-0.24.1-cp27-none-win_amd64.whl 

It displays an error:

rasterio-0.24.1-cp27-none-win_amd64 is not a supported wheel on this platform.

I have tried all the binaries given at http://www.lfd.uci.edu/~gohlke/pythonlibs/#rasterio but none has worked.

It's installation requires GDAL also and when I try any of the GDAL binaries it gives the same error message as that for rasterio but nevertheless I have installed GDAL with OSGeo4W installer. Now how do I go about installing rasterio? Please suggest something.

  • 3
    You use Python 2.7 and you are trying to install the version for Python 3.4 (cp34) – gene Jul 2 '15 at 14:52
  • Sorry, I just gave an example and mistakenly that of python 3.0 but I have tried all the binaries that are compatible with python 2.7 and none worked. I'll make the changes in the question. Thank you for pointing out. – rach Jul 2 '15 at 15:46
  • 2
    Is your python 64bit or 32bit? – user2856 Jul 7 '15 at 11:26
  • 1
    Read carefully the text at the top of Gohlke's index page and also this pip.pypa.io/en/latest/user_guide.html#installing-from-wheels that he links to. – sgillies Aug 21 '15 at 16:08
  • For complete beginners on Windows trying to get it to work inside QGIS: This might be useful. – weiji14 Jul 31 '16 at 23:27
1

I finally managed to get past this problem by systematically going through all of the supporting requirements for rasterio.

One of the key things that helped was:

pip install wheel --upgrade

However also, I touched many many of the other modules (upgrading GDAL, numpy, click and Cython ) before finally getting to the point where

pip install rasterio-0.24.1-cp27-none-win_amd64.whl would finally work for me.

I had success using this method, but then also ran into some later problems to which I am now searching for answers!

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.