4

I am using QGIS 2.8.2 and I'm trying to geocode some addresses, but when I run it, I get this error:

An error has occurred while executing Python code:

Traceback (most recent call last):
  File "C:/Users/Home/.qgis2/python/plugins\mmqgis\mmqgis_dialogs.py", line 1198, in run
    shapefilename, notfoundfile, fields, service, 1)
  File "C:/Users/Home/.qgis2/python/plugins\mmqgis\mmqgis_library.py", line 1910, in mmqgis_geocode_web_service
    notwriter.writerow(row)
Error: need to escape, but no escapechar set

Python version: 2.7.4 (default, Apr 6 2013, 19:54:46) [MSC v.1500 32 bit (Intel)]

QGIS version: 2.8.2-Wien Wien, 1b929ef

Python path:

['C:/PROGRA~2/QGISWI~1/apps/qgis/./python/plugins\\processing',
'C:/PROGRA~2/QGISWI~1/apps/qgis/./python',
u'C:/Users/Home/.qgis2/python',
u'C:/Users/Home/.qgis2/python/plugins',
'C:/PROGRA~2/QGISWI~1/apps/qgis/./python/plugins',
'C:\\PROGRA~2\\QGISWI~1\\bin\\python27.zip',
'C:\\PROGRA~2\\QGISWI~1\\apps\\Python27\\DLLs',
'C:\\PROGRA~2\\QGISWI~1\\apps\\Python27\\lib',
'C:\\PROGRA~2\\QGISWI~1\\apps\\Python27\\lib\\plat-win',
'C:\\PROGRA~2\\QGISWI~1\\apps\\Python27\\lib\\lib-tk',
'C:\\PROGRA~2\\QGISWI~1\\bin',
'C:\\PROGRA~2\\QGISWI~1\\apps\\Python27',
'C:\\PROGRA~2\\QGISWI~1\\apps\\Python27\\lib\\site-packages',
'C:\\PROGRA~2\\QGISWI~1\\apps\\Python27\\lib\\site-packages\\PIL',
'C:\\PROGRA~2\\QGISWI~1\\apps\\Python27\\lib\\site-packages\\jinja2-2.7.2-py2.7.egg',
'C:\\PROGRA~2\\QGISWI~1\\apps\\Python27\\lib\\site-packages\\markupsafe-0.23-py2.7-win32.egg',
'C:\\PROGRA~2\\QGISWI~1\\apps\\Python27\\lib\\site-packages\\python_dateutil-2.2-py2.7.egg',
'C:\\PROGRA~2\\QGISWI~1\\apps\\Python27\\lib\\site-packages\\pytz-2014.2-py2.7.egg',
'C:\\PROGRA~2\\QGISWI~1\\apps\\Python27\\lib\\site-packages\\win32',
'C:\\PROGRA~2\\QGISWI~1\\apps\\Python27\\lib\\site-packages\\win32\\lib',
'C:\\PROGRA~2\\QGISWI~1\\apps\\Python27\\lib\\site-packages\\Pythonwin',
'C:\\PROGRA~2\\QGISWI~1\\apps\\Python27\\lib\\site-packages\\Shapely-1.2.18-py2.7-win32.egg',
'C:\\PROGRA~2\\QGISWI~1\\apps\\Python27\\lib\\site-packages\\six-1.6.1-py2.7.egg',
'C:\\PROGRA~2\\QGISWI~1\\apps\\Python27\\lib\\site-packages\\wx-2.8-msw-unicode',
u'C:/Users/Home/.qgis2//python',
'C:\\Users\\Home\\.qgis2\\python\\plugins\\mmqgis/forms',
'C:\\PROGRA~2\\QGISWI~1\\apps\\qgis\\python\\plugins\\fTools\\tools']
  • Welcome to GIS:SE Kai! Are you using the latest version of the MMQGIS plugin? – Joseph Jul 6 '15 at 13:53
  • Hi Joseph, Yes I am. Thank you for taking the time to answer my qustion. :) – Kai Jul 7 '15 at 12:02
  • can you send some line of your dataset you want to geocode and which of ressource are you using to geocode your adress (google, OSM, your own table)? – Hugo Roussaffa - GeoDatup Sep 25 '17 at 10:08

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.