This is a snip of what I see on my screen when I choose to the OpenCycleMap from the OpenLayers Plugin.

It happened on version 2.6 and I was told it was my version that was the trouble, so I reverted to 2.2. The odd thing is, that it will usually work fine the first time I open the map, but it seems like with each additional use more white squares pop up. This is happening with the OpenStreet and OCM layers. It does not seem to happen with other layers.

Any thoughts?

  • It's usually a good idea to tag your questions with the software you are using (I've added QGIS for you). Does this happen at all zoom levels or just particular ones? Any specific areas? – Evil Genius Jul 10 '15 at 15:28
  • Hi, thank you. I just realized it is also happening with the other openstreet and OCM layers so updated my question. I have been working on Texas, and it seems to happen at all zoom levels. I am a beginner--likely doing something obviously wrong, but I am so new I don't know where to begin. I have the CRS enabled to "on the fly" and using WGS84/UTM zone 15N. – surveyor Jul 10 '15 at 15:33
  • I don't know how to fix your problem. But you may try to load this file as a raster layer gdal.org/frmt_wms_openstreetmap_tms.xml to over take your problem. – etrimaille Jul 10 '15 at 16:51

The reason for the missing tiles is that the tile server is responding too slow if it suffers heavy load from other users. Unfortunately, there is no option in the plugin to extend the timeout.

You can try increasing the values under Settings -> Options -> Network tab; or simply move around the whole canvas to activate a reload of the tiles.

Or use another tile server, like Mapquest. But they might not have the OpencycleMap designed tiles.

Apart from that, I suggest to set the project CRS to the native projection of the tiles, that is EPSG:3857.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.