I have a big problem - I installed google earth for a project and when I went to uninstall chrome that it forced onto my computer now Arctoolbox won't work at all. I can see the toolbox but whenever I click on a tool it tries to open a chrome html and I get an error Navigation to the webpage was canceled.

I've tried to search on the internet, reboot, anything. I don't understand why this is happening and I really need ArcMap back!

also I don't really want to uninstall - I have the educational version and I don't think I can reinstall it again.

  • Have you tried opening Internet explorer (or firefox) and setting it as your default web browser? – Kirk Kuykendall Oct 6 '11 at 16:32
  • Not that this helps, but I'm just curious as to why you're so determined not to have Chrome on your computer. It's a great browser... – Stephen Lead Oct 6 '11 at 23:48
  • I am happy with firefox and dislike how google sneakily tries to get you to install chrome all the time. Yes I have set it back to my default browser. It must be related somehow because after I reinstalled a lot of stuff in firefox didn't work. I just deleted the arctoolbox folder because I saw in another thread that might work. But it still doesn't. – Nevu Oct 7 '11 at 1:11
  • Fair enough. Re: the educational version, I believe this is simply the standard ArcGIS install with a different license arrangement (ie, it's a legal/marketing difference rather than an actual technical difference) so it is possible to uninstall and reinstall, provided you still have the original DVD and license codes – Stephen Lead Oct 7 '11 at 1:44
  • yea I might have to try that since I tried reinstalling chrome and it still doesn't work. I am reluctant to reinstall because I had arcmap on my other pc and it had to be reformatted, and when I went to reinstall it it said my auth code was in use. I'm pretty sure I have to reinstall, deauth, install again, and authorize again. It seems like a giant hassle for something that chrome did! grr. – Nevu Oct 7 '11 at 2:14

Can you check what the default html browser is? I've noticed that ArcToolBox uses some part of Internet Explorer and ActiveX. I wonder if the default browser was changed and whether this might affect it. For example here is a thread about problems with Internet Explorer and ActiveX.

Failing that, have you considered reinstalling Chrome? Not ideal of course as it's not a solution and presumably you don't want it, but if it makes ArcGIS work, it might be worth doing.

  • Hi, thanks. I fixed everything back in my firefox browser as it seems to have ruined that too. I don't see how arctoolbox is related to webpages but the folder is located here Roaming\ESRI\Desktop10.0\ArcToolbox\Dlg and they all seem to be associated with html files. – Nevu Oct 6 '11 at 15:52
  • I tried reinstalling and installing and still the same problem – Nevu Oct 8 '11 at 11:18

Try this:


Cause Program access and defaults are not set to Microsoft Windows.

Solution or Workaround Setting the program access and defaults to Microsoft Windows allows ArcGIS to properly open geoprocessing tools.

  1. Close any running ArcGIS applications.
  2. For Windows XP: From the Start menu, open 'Set Program Access and Defaults'.

    For Windows Vista / Windows 7: From the Start menu, open 'Default Programs', then click 'Set Program Access and Computer Defaults' in the next window.

    1. Choose 'Microsoft Windows' and click 'OK'.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.