I am developing an Addin for ArcMap 10. There are two combo boxes that I use. On several of my users's computers, they get this extra text next to the combo box. It appears it is text from the "Caption" attribute in the Addin xml. I can reset the tool bar but the text comes back after I load any MXD (even new fresh ones with nothing in them). I can not replicate this on my computer, or my co-workers. It only appears on a few users computers in different offices.

I have checked everything they have installed, and found the production tools for 10, but haven't found that causes the problem. They say they have a custom VBA script they use to load some data points, but I can't find any of the VBA code being executed using the VBA editor.

I have also found that in customize mode, I can "Browse for image" and change the image, which makes the text go away, but as soon as I go back to the MXD, this setting is reset. The "Default Style" is checked but greyed out, along with the other options.

Here is my current snipplet of XML for first combo box:

     tip="Target Plot Layer"
     category="Canopy Cover"

Here is a picture of the issue: Arcmap Addin combo box problem

Has anyone encoutered this problem? Can I disable this in my code, or even overide this in code some how? Does anyone know the cause of this?

  • Have you tried having the affected users delete their Normal.mxt (back it up first, this is where ArcMap stores all user interface customizations)?
    – blah238
    Commented Oct 6, 2011 at 20:39
  • @blash238 It doesn't appear to affect that at all. I removed the Normal.mxt out of there and let it create a new one (it said Generate ArcId Module on restart) but the problem still persists.
    – Erik L
    Commented Oct 6, 2011 at 21:06
  • Not from the VBA editor, from the user's %APPDATA%\ESRI\Desktop10.0\ArcMap\Templates folder.
    – blah238
    Commented Oct 6, 2011 at 21:27
  • Correct. I took out the Normal one, along with another one that was in there. Tried it, and same problem.
    – Erik L
    Commented Oct 6, 2011 at 23:49

1 Answer 1


This apparently broke in service pack 2, and I think it is related to "NIM061350 - ICommandItem.Style property does not work in ArcGIS 10.0."

Here is the code that I used to fix the combo boxes in an Addin, place this in the OnUpdate()

UID uid = new UIDClass();
uid.Value = //your ID for the tool
var comboBox = ArcMap.Application.Document.CommandBars.Find(uid);
if (comboBox.Style != esriCommandStyles.esriCommandStyleIconOnly)
   comboBox.Style = esriCommandStyleIconOnly;

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.