3

I think I've managed to bust GDAL after (I think) installing Grass7. I had previously built GDAL (1.10) from source with a bunch of additional drivers. When installing Grass7 GDAL 1.11 was installed. QGIS threw a bunch of errors when loading plugins I assume because I built QGIS against Gdal 1.10. I tried to downgrade GDAL in synaptic package manager from 1.11 to 1.10 (gdal-bin; libgdal-dev; libgdal1h) which has allowed me to run QGIS without errors.

However, all sorts of strange behaviour now from QGIS/GDAL now. For example, when attempting to import a shapefile to postgis using the processing toolbox - the application crashes. When attempting to import the shapefile via ogr2ogr from the command line - the driver throws the following error:

Warning 1: Geometry to be inserted is of type Multi Line String, whereas the layer geometry type is Line String.

Insertion is likely to fail ERROR 1: INSERT command for new feature failed. ERROR: Geometry type (MultiLineString) does not match column type (LineString)

All seems to point to broken GDAL - I seem to remember managing to do this once before and having to rebuild gdal and qgis from scratch. This is something I want to avoid, so wondered if there are any quick fixes? That said, I should probably upgrade gdal to 1.11 (but with driver support for kml, mrsid, ecw, etc) and build QGIS against this library - does anyone have a script or link to a script to achieve this without to much headache?

How do you keep on top of version changes of GDAL/QGIS when you've built from source?

Ubuntu 14.04 LTS QGIS 2.10 Pisa GDAL 1.10

1

I would not be too sure that the downgrade from GDAL 1.11 to 1.10 was really clean. If you want to stick to that GDAL version, I suggest to re-build QGIS again with it.

Upgrading to GDAL 1.11 is surely better, but if you need ecw support on Ubuntu, you might run into problems there (see Unable to install ECW support on lubuntu 14.04 for that). On the other hand, most devs who worked on QGIS 2.10 will have worked with GDAL 1.11, so you might run into problems with new features if you stick to the old GDAL version.

0

I'd think twice before upgrading to GDAL 1.11 if I was you... I also broke my GDAL by installing GRASS 7, so I upgraded to GDAL 1.11.2, and QGIS 2.8. At first this seemed to so fix things, but then I noticed some strange behaviour in QGIS, which I now believe is caused by the new GDAL. When I load rasters, they often appear in wrong locations, and the raster merge tool seems to truncate my images half way down, or place negative values in the file extent field. On closer inspection, I found that GDAL now often misinterprets geo-tags from older geotiff files, created with GDAL 1.6. Also, I developed a little tool some time ago, for viewing geotags, which still works fine on geotiff files created with gdal 1.6, but fails to read geotags from files created by the new gdal_translate in gdal 1.11. There seems to be a definite file incompatibility between the gdal 1.6 and 1.11.2. I'm still trying to pin down at what point the incompatibility started, but I'm pretty sure gdal 1.10 still worked ok.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.