3

I'm using QGIS 2.6 and regularly update a shapefile layer to indicate felling progress. However, if I edit the nodes of a polygon, save the layer out then look at the Attributes table the area shown doesn't change.

2
  • 1
    Shapefiles don't support automatic updating of the/an area field. Some formats do, such as an Esri file geodatabase. You must manually recalculate the area any time you make changes. Joseph points out you can use a virtual field, but as noted that's only in a QGIS project file (similar to an ArcGIS mxd) - it's not actually part of the data. What you really need to do if distributing the shapefile is re-run that $area field calculation on your area field each time you revise the file. – Chris W Jul 18 '15 at 20:13
  • You can achieve it using the AutoFields plugin. Watch this video for an example of auto-updating geometric properties. In your case, you would just need a field and to choose Area in the expression options of the plugin's interface. – Germán Carrillo Aug 19 '16 at 16:57
3

You can create a Virtual field which updates features automatically based on the expression you insert. So in your case, it would be:

$area

Field Calculator for virtual field

You will need to create a Project for the shapefile (if you haven't done so already) as virtual fields are stored in the project files (.qgs).

1

The identify tool provides a quick way to access area measurements. You can change the units by going to:

Project menu > Project Properties | General > Measurements

enter image description here

WARNING: Sometimes area calculated in QGIS is wildly inaccurate. This can happen regardless of whether you use the identify tool or the field calculator in the attribute table. It's usually a result of having multiple layers with different coordinate reference systems in the same project. If you start seeing area numbers that don't make sense, try loading the layer into a blank project, turn off on-the-fly reprojection, and redo the calculation using field calculator.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.