1

I was trying upload geofabric's netherlands-latest file into Nominatim's database. I used bellow command and all was fine: ./utils/setup.php --osm-file maps/netherlands-latest.osm.pbf --all 2>&1 | tee setup.log But suddenly, I got the following error:

Processing: Node(100308k 215.7k/s) Way(13517k 25.85k/s) Relation(107730 1210.45/s)  parse time: 1077s

Node stats: total(100308187), max(3651340162) in 465s
Way stats: total(13517172), max(360615308) in 523s
Relation stats: total(107736), max(5369205) in 89s
node cache: stored: 100308187(100.00%), storage efficiency: 58.77% (dense blocks: 70357, sparse nodes: 49312332), hit rate: 100.00%
Stopping table: planet_osm_nodes
Stopping table: planet_osm_rels
Stopping table: planet_osm_ways
Building index on table: planet_osm_rels (fastupdate=off)
Building index on table: planet_osm_ways (fastupdate=off)
Stopped table: planet_osm_nodes in 0s
Stopped table: planet_osm_rels in 0s
CREATE INDEX planet_osm_ways_nodes ON planet_osm_ways USING gin (nodes)  WITH (FASTUPDATE=OFF);
 failed: server closed the connection unexpectedly
        This probably means the server terminated abnormally
        before or while processing the request.

Error occurred, cleaning up
ERROR: Error executing external command: /opt/Nominatim/osm2pgsql/osm2pgsql -lsc -O gazetteer --hstore -C 2002 -P 5432 -d nominatim /opt/Nominatim/maps/netherlands-latest.osm.pbf
Error executing external command: /opt/Nominatim/osm2pgsql/osm2pgsql -lsc -O gazetteer --hstore -C 2002 -P 5432 -d nominatim /opt/Nominatim/maps/netherlands-latest.osm.pbf

I didn't find any definite answers.


I've tried changing the order of installation. First, I've started
./utils/setup.php --create-db --setup-db --create-functions --create-tables Second, I started import through osm2pgsql like: osm2pgsql/osm2pgsql -s -S osm2pgsql/default.style -C 2000 -U postgres -d nominatim -k -c --number-processes 2 maps/netherlands-latest.osm.bz2 and got there http://pastebin.com/Fpfsv2xv

  • Now, I've tried small region like Bulgaria, which file has been downloaded a few years ago and it seems work fine. TIs that the latest file's problem or maybe I should use another geos library's version? – Andrey Maraev Jul 15 '15 at 13:15
  • 1
    "server closed the connection unexpectedly" -> what does the server log say? – scai Jul 15 '15 at 17:28
  • hi scai, pg_logs here pastebin.com/Fxn1bhh0 – Andrey Maraev Jul 16 '15 at 7:58
  • It says "database "nominatim" does not exist". – scai Jul 16 '15 at 8:20
  • update pg_logs: pastebin.com/CGSAchit I suspect that postmaster PID terminated due to memory cache not enough, though maybee anyone can get any suggestions. Thanx! – Andrey Maraev Jul 17 '15 at 11:59

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.