4

So far I have been using OSGeo4W shell (or OSGEO install) as really convenient way to use python together with additional packages, namely gdal, shapely, numpy, scipy and matplotlib.

I was happy till I came to the point where I need to start use also pandas and VTK packages.

I came across Anaconda, which allows me to easily install everything including the needed pandas and VTK packages. But when I run my scripts which were working well with OSGEO, with Anaconda it comes with:

ERROR 6: GEOS support not enabled.

I have installed GDAL from https://binstar.org/osgeo/gdal where it is written: "Built with all command line tools and with GEOS and HDF5 support". But obviously something is wrong. I also tried install additionaly first geos and after that gdal from https://conda.binstar.org/osgeo but ended up with the same error.

I found a post talking about this issue linking to special package build gdal_geos on binstar. But there is verion only for linux-64.

So ideally both ways or at least one of these: Can I easily add pandas and VTK support to OSGeo4W shell? And/Or how to make work GDAL with GEOS support on Anaconda install?

Update: I have installed Fiona package to Anaconda and replaced OGR part (load (and buffer with Shapely) objects from shapefile) by it and the code works. If I switch back to OGR, error comes up again.

2

As one of the maintainers of the 'osgeo' conda channel (which, as noted on the project description had no affiliation with the OSGEO foundation and was only intended for internal builds of 'osgeo' packages) I would highly recommend you don't use these builds of GDAL.

Instead install from the conda-forge channel, their builds of GDAL are kept much more up to date than the default and build with a lot more options (including GEOS) support.

To install GDAL from conda-forge use:

conda create -n gdal_env -c conda-forge gdal
activate gdal_env

Installing in a separate environment is needed so that environmental variables required by GDAL are set correctly.

We have now removed the osgeo channel.

  • Thank you. Most probably I won't have time to test it any soon so I am accepting this answer in believe that answer from maintainer of osgeo channel will work :) – Miro Aug 29 '16 at 12:37
0

That error tends to occur unless the GDAL library is specifically compiled with GEOS support (as explained on the GDAL development mailing list).

For example, on ubuntu linux you would use the software centre to ensure libgeos (and libgeos-dev) are installed, then use "git" to download a clone of the GDAL repository from github, run the configure script using arguments to switch on support for both python and GEOS (neither of which seem to be on by default), then use "make" to install GDAL. But if you're reliant on a pre-compiled binaries, you could try asking for an update from the maintainer upstream of you.

0

I've had success using GDAL on Windows 7 with Python 3.4 building from the wheel files provided here: http://www.lfd.uci.edu/~gohlke/pythonlibs/

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.