After dissolving a layer in QGIS 2.8, I get a lot of topological errors in the new (dissolved) layer. Any suggestions as to how to get rid of these errors without manually editing each one?



trying to use @Josephs suggestion I get a strange error message:


  • 2
    Possible duplicate of gis.stackexchange.com/questions/97986 though it may be the best solution is in a comment on my answer rather than the answer itself. In addition to rmdangle you might consider rmarea. cc @joseph Also, another term that may help in researching is sliver polygon - I can't tell if your errors are polygons or just holes. See gis.stackexchange.com/questions/11004 for approaches from a variety of software.
    – Chris W
    Jul 18, 2015 at 18:45

3 Answers 3


Instead of remove dangles you can correct the original layer. Use v.clean like Joseph says but run the tool v.clean.snap on your original borders layer, set the tollerance (for borders I think you can use a big value but you have to try) and then try again to dissolve.

You can find eventualy remaining dangles using Topology Checker and "Must not have gaps".


You could try using the GRASS function v.clean and selecting the rmdangle which aims to remove any annoying dangles. You could access this from the Processing Toolbox.

v.clean interface

You can set the "threshold" option which determines what dangles can be deleted:

The rmdangle tool deletes a dangle if the (combined) length is shorter than thresh or thresh < 0. If the combined length is larger than thresh, nothing is deleted.

  • thanks for your suggestion, but it does not work for me, see error-message in my screenshot above.
    – Kurt
    Jul 16, 2015 at 16:23
  • 3
    That error probably depends by some strange (german) chars inside data. Set the codec of the shape to UTF-8 (using plugin "shapefile encoding fixer") and look at your table for find some errors (you see a black "?") correct them and retry. Another, easier, way is try to import into grass the layer and after that using the tool inside grass with the grass plugin.
    – Sergio
    Jul 27, 2015 at 11:15
  • @Sergio - That's a good point, very well picked up!
    – Joseph
    Jul 27, 2015 at 11:18
  • @Sergio: At the end I fixed the errors manually. But thanks for your hints- the will hopefully be helpful in future-projects. And of course your are right, that it is better to fix the original layer that the final (dissolved) one ....
    – Kurt
    Jul 29, 2015 at 6:57

For me this worked: processing toolbox > 'Delete Holes' and run without any minimum area.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.