11

we are working on one big layer at the same time (10-20 people). Some of us use QGIS 2.8.1 and the other 2.6. The user with 2.8 have a lot of crashes (QGIS). The 2.6 users don't have this crashes but to add a feature is incredible slow. The Postgres 9.4 server is running on a Virtual Machine (Hyper V) with Win7. Maybe it's the network and not QGIS? Maybe someone have an idea. Would be great :)

  • how much RAM is available for Postgres HyperV might need more see > Hyper-V Overhead technet.microsoft.com/en-us/magazine/hh750394.aspx been there and increased to 16GB – Mapperz Jul 16 '15 at 20:16
  • You really should upgrade to 2.8.2 - it includes lots of fixes over 2.8.1. I can't recall offhand if any would relate to crashing with postgis, but it can't hurt to try... – ndawson Jul 16 '15 at 21:59
  • Does each user connect with the same login? PostGIS does perform better on Linux but I'd say it would be best to get it running on its' own workstation (server) rather than a virtual machine. There are a few PostgreSQL performance tuning tips, Google that and see what others are saying.. questions regarding the performance of PostgreSQL and tuning would be best asked on dba.stackexchange.com – Michael Stimson Jul 16 '15 at 23:55
  • @MichaelMiles-Stimson yes everyone connect with the same login. Could this be a problem? – gustavgans Jul 17 '15 at 5:14
  • Now all of us are working with 2.6.0 and 2.6.1. No crashes anymore. We also tried it with 2.8.2 but after saving one feature Qgis crashed. – gustavgans Jul 17 '15 at 7:46
1

Below the answers posted in the comments :

  • (@Mapperz) HyperV might need more RAM memory : See Microsoft technet article (Hyper-V Overhead). Try increasing to 16GB

  • (@ndawson) Try to upgrade QGIS on the lastest versions

  • (@Michael Stimson) PostGIS does perform better on Linux, but if possible, get it running on it's on workstation (server) rather than a virtual machine. Have also a look for questions regarding the performance of PostgreSQL and tuning on Database Administrators Stack Exchange. If everyone connect with the same login the tablespace can get a little cluttered and lots of objects juggling around. It is not the best but will still work. I think the best thing is to put it on its own computer (not VM) and have the data on SSD/RAID.

  • (@RustProof Labs) RAM, disk speed, processor load and network speed could all affect performance, it's hard to say without having monitoring in place to see where the bottleneck is. One thing I have had success with is increasing the cache sizes in QGIS to allow the individual machines to store more locally and reduce load on the server. I think the defaults were around 50MB, I've upped mine more to the 200 MB range with good results.

  • (@Luigi Pirelli) You should follow these steps to understand if there is a Postgres provider bug or local installation issue:

    • A) test with qgis on different platforms, win, linux, mac
    • B) look for a replicable crash
    • C) Always share the error or log
    • D) Check with dev version to have log enabled....

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.