1

My problem: An Arc GIS Schematics diagram export with versioned oracle/sde GIS features can't be reconnected to GIS data on another oracle/sde instance.

I'm working on a project where in the first phase we created a railroad network stored in ESRI SDE 10.2.0 in Oracle. This network we exported via XML-Workspace to the customers SDE. In the next phase we started creating schematic diagrams at our SDE which now we would like to migrate and reconnect to their SDE.

The OBJIDs of the GIS features stay the same though the FCIDs are changed when importing the workspace to their SDE.

When reconnecting (setting the new data sources in the schematic dataset) the diagrams (which we exported for transport to a fgdb) to the SDE at the customer via OBJID and FCID - everything seems to work till we update the diagrams (against original query – with persist option). Here we get an error message:

"No initial objects can be retrieved. Unable to update the diagram. Check to make sure the underlying version exists."

following with a German message that the geometric network also isn't found in case we try to reconnect in a fgdb.

Also Feature Info requests don´t point to the original GIS feature classes.

When updating with the Toolbox tool "update diagram" the same error message appears unless I explicitly set the datasources. But in this case (even with the Update/Keep_manual_edits option) the original query and the manual edits are lost.

When manually changing the UCID (FCID) in the schematic features the Feature Info requests recognize the GIS features again.

Last thing I tried was changing UCID, Schematicid/schematictid, FROMTID & TOTID in all the involved schematic feature classes in a diagram manually and then perform an update. This completes without error messages but many of the schematic features disappear after an update (though not all).

Also I noticed that UCID etc. are stored in A and E tables so there might be other places to manually edit stuff & I don't know if this is really wise to change too much in the diagrams "internals".

We are working with ArcGIS 10.2.0. The diagrams are based on the standard builder and input comes from a geometric network which consists of 3 node feature classes a line feature class and 1 nodeonlink feature class. The GIS features are stored in our oracle db in a versioned feature dataset.

Based on the error message - has this something to do with the versioning of the GIS features?

Does anyone have experience with exporting Schematic datasets and know a solution? (On a sidenote: we didn't try Global IDs till now - kind of would like to avoid it - unless it is absolutely necessary.)

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.