4

I face the problem that not all tiles are loaded on a map export via the QGIS composer. This happens randomly with all kinds of tile servers provided by the openlayers-plugin.

Tiles not loaded

Any hint how I can force loading the tiles before the image is saved?

I hope this is not a duplicate - I've been looking through existing threads thoroughly but haven't found anything.

Edit: Specs: well equipped ThinkPad x230 with Ubuntu 12.04 LTS and QGIS 2.8. Internet-connection not very good at the moment.

  • Is this created using the web data and not raster tiles? – Ger Jul 17 '15 at 13:43
  • hmm, don't know to be honest. It is created using the openlayers-plugin GUI. Its loading the data when I scroll around in QGIS, too. – Klaster Jul 17 '15 at 13:49
  • try my answer below and if it does not work i will delete it. – Ger Jul 17 '15 at 13:51
  • Hmm while I'm sure that it works as a work-around, I honestly hope to be able to avoid this method by waiting for better internet connection. :o\ I was hoping to be able to increase the waiting time for the tiles or sth like that. – Klaster Jul 17 '15 at 13:54
  • I've found that going back to the map composer window and waiting a minute or so helps. I suspect the tiles are being fetched in a background thread but QGIS lets you export before this process has finished. – Steven Kay Jul 17 '15 at 15:39
1

Assuming the problem is relating to web loaded background mapping, the method i have found for a solution is as follows....please note i am open to suggestions for improvements or corrections.

load your layer in. turn off any other layer, so you have plain background mapping.

zoom to a close level with lots of detail

click project, save as image for that screen.

reposition the viewer so that there is an overlap of the next image.

click project, save as image for that screen.

Typically i save around 9 - 16 images, then load them in as rasters, then load my other vector data across it.

I find that the problem is an internet connection speed issue.

Also of note is that the other way, you do not get a to scale drawing, this way you do!

Please correct me and dont down vote me!

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.