2

I'm getting this error message when I start QGIS

Couldn't load plugin sextantelwgeomprovider due an error when calling its classFactory() method

Traceback (most recent call last): File "/usr/lib/python2.7/dist-packages/qgis/utils.py", line 204, in startPlugin plugins[packageName] = package.classFactory(iface) File "/home/sara/.qgis2/python/plugins/sextantelwgeomprovider/init.py", line 50, in classFactory from sextantelwgeomprovider.SextanteLwgeomProviderPlugin import SextanteLwgeomProviderPlugin File "/usr/lib/python2.7/dist-packages/qgis/utils.py", line 453, in _import mod = _builtin_import(name, globals, locals, fromlist, level) File "/home/sara/.qgis2/python/plugins/sextantelwgeomprovider/SextanteLwgeomProviderPlugin.py", line 28, in from sextante.core.Sextante import Sextante File "/usr/lib/python2.7/dist-packages/qgis/utils.py", line 453, in _import mod = _builtin_import(name, globals, locals, fromlist, level) ImportError: No module named sextante.core.Sextante Python version: 2.7.6 (default, Jun 22 2015, 18:01:27) [GCC 4.8.2]

QGIS version:

2.0.1-Dufour Dufour, exported

Python path:

['/usr/share/qgis/python', '/home/sara/.qgis2/python', '/home/sara/.qgis2/python/plugins', '/usr/share/qgis/python/plugins', '/usr/lib/python2.7', '/usr/lib/python2.7/plat-x86_64-linux-gnu', '/usr/lib/python2.7/lib-tk', '/usr/lib/python2.7/lib-old', '/usr/lib/python2.7/lib-dynload', '/usr/local/lib/python2.7/dist-packages', '/usr/lib/python2.7/dist-packages', '/usr/lib/python2.7/dist-packages/PILcompat', '/usr/lib/python2.7/dist-packages/gtk-2.0', '/usr/lib/pymodules/python2.7', '/usr/lib/python2.7/dist-packages/ubuntu-sso-client', '/usr/lib/python2.7/dist-packages/wx-2.8-gtk2-unicode']

Because of that I can't use any geoalgorithms. Is there a way of solving the bug: "No module named sextante.core.Sextante"?

I tried to fix it by using Plugin > Manage and Install Plugins... but I still receive and error message "The plugin requires a missing module sextante.core.Sextante". How can I install this module?

  • I think your QGIS version and therefore your processing plugin is completely outdated. Consider updating to at least QGIS 2.8 – Bernd V. Jul 19 '15 at 13:40

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.