2

To be honest I'm not sure how to run LAStools from within QGIS 2.8. I'm trying to learn by experimentation. QGIS shows all the LAStools in the toolbox

If I double click on a LAStool in the toolbox I get the following message:

Missing dependency. This algorithm cannot run :-( LAStools folder is not configured. Please configure it before running LAStools algorithms.

I can't find any LAStools *.exe files anywhere within my QGIS Wien file structure. That makes me wonder how I could have LAStools show in the toolbox. Could it be a *.dll somewhere?

What am I doing wrong?

2

There is a lot of help available on how to configure LAStools for QGIS. First check the original blog post about it (including all comments). If you speak Spanish then there is also this option here. And if all this does not help then search for QGIS in the LAStools user forum.

1

As stated by Mapperz there can't be any white spaces or special characters (like ö, ç, etc.) in the software path and input file paths. Here you can find the same issue (and answer) reported in the lists.osgeo.org mailing list.

The issue was also brought up in the LAStools mailing list for QGIS 2.0.1 and Ubuntu 14.04. A workaround according to Edgar was to edit a text file ‘processing.conf’ in the QGIS user folder, and alter the line lastools_folder= to include the software path (for example: lastools_folder=C:\LAStools). This was also corroborated by I. Reid's comment in rapidlasso.com.

Lastly, best alternative would be to upgrade QGIS to newer versions, where this problem seems to be resolved.

0

A late answer but because I ran into the exact problem I thought I would post my solution here directly so people looking here first (like me) would have my solution laid out.

If you have set everything up as per the documentation, just make sure you have set your LAStools folder path to where you have extracted LAStools (with no spaces as mentioned in the other answers. This is located in:

Processing > Options... > Providers > Tools for LiDAR data > LAStools folder

For reference I used "QGIS_2_2_toolbox" and my path was: C:\LAStools

It is worth mentioning that I did this once and pressed OK and it didn't save. So if you think you have done it, just check again to be sure.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.