1

I'm new to this, so please go lightly if I'm asking something obvious.

I imported an Excel file with 9,159 entries and I'm mystified as to why 841 are cartodb_georef_status false and another 36 null. So, something like a tenth of the data isn't getting mapped. Many are international addresses which I am less familiar with, but even American addresses like:

fname lname nickname 1609 Mulberry Lane Wentachee WA 98801 USA

get false and

fname lname nickname 301 Church Street Mount Calvary WI 53057 USA

gets a null.

These seem like legit addresses to me and both of the above examples return valid results on Google maps.

1
  • You're correct, I didn't phrase that as clearly as I could have. I'll change the title and hope that a CartoDB person can weigh in. Jul 21 '15 at 2:49
1

If the dataset was geocoded automatically by the upload, it was geocoded by your city column but not by the address.

CartoDB, unless disabled in the Connect Dataset section, tries to guess automatically the types of the columns and also tries to get a column for which the dataset could be geocoded by Country name, City name or IP address.

Probably CartoDB found your city column and it run the city names geocoder against it, but the complete address would need a manual geocoding by using the "Street Addresses" option which requires geocoding credits as it is offered via a geocoding provided and not directly by CartoDB as the other options are.

If you want to geocode your dataset by address, you'd need to remove the cartodb_georef_status column and configure the geocoding process with the street addresses option.

The reason why not all the dataset was geocoded is simple: the system didn't detect the names. This could be caused because the system doesn't contain a name at all, or because CartoDB recognizes it with another different name.

CartoDB uses the Geonames database in order to geocode city names, so you could try to find the city there and check which nomenclature is the database using. Notice that only the geonames locations specified as "Populated places" (marked with a white icon and the letter P) are in the CartoDB geocoding database.

You could also post the not geocoded cities here to see if there's something we could help you with.

4
  • Here's the list: Jul 21 '15 at 13:24
  • Here's the list of cities that are in SELECT distinct(CITY) FROM sasquan_201507_19 WHERE cartodb_georef_status IS false OR cartodb_georef_status IS NULL pastebin.com/rnzDKFy0 Any help appreciated. Jul 21 '15 at 13:49
  • Weird, I'm seeing there cities that I'm sure are recognised. Which is your username? Perhaps this was due to an error (for example, a quota error)
    – iriberri
    Jul 21 '15 at 15:23
  • Thanks! I'm seeing that geocoding manually the datasets gets more data geocoded, so this seems to be something related with the automatic guessing
    – iriberri
    Jul 23 '15 at 16:02

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.