I'm attempting to export a .dae collada file from Photoscan to ArcScene 10.1. I've followed instructions from a couple of sources, created the file geodatabase, imported the file as a multipoint feature into the geodatabase, however, after import the mesh shows fine but without the texture detail: just a solid block of colour. I've checked and haven't imported as a shapefile by mistake. I can't work out why Arcscene isn't 'seeing' .jpg texture file which is located alongside the .dae file. Works fine when i export from Photoscan to Meshlab.

I've checked online and people seem to have similar problems with .dae files in different pieces of software incl. Blender, as well as ArcGIS.

Is there any way to link the mesh to the .jpg in ArcScene?

3 Answers 3


If possible try to convert it to a .3ds file. I have had more luck with those than .dae for preserving texture.

  • Thanks for the help but still no luck. Just wondering whether to keep tinkering with different formats till I find something that works. Or maybe Arc just doesn't like way I exported it...
    – MuckaG
    Commented Jul 20, 2015 at 20:11
  • That could be. I often find myself tinkering with different file formats until one works. Lately I've been using ArcGIS Pro and multipatches to look at 3D Models with ArcGIS. Commented Jul 20, 2015 at 20:13
  • Yeah, should have access to the latest ArcGIS when I start my new job. Starting to think it's just a bug...
    – MuckaG
    Commented Jul 20, 2015 at 20:35
  • I would recommend giving ArcGIS Pro a shot when you get a chance, for modeling it works better than ArcScene. I will keep looking into this for you. Commented Jul 20, 2015 at 20:37

I had that issue until I followed this youtube video. It works perfectly. You need a geodatabase first and then you import the COLLADA along with the .jpg or .tiff



We had the exact same problem. We did everything according to the video but textures did not show up. Only when we decreased the pixel length of the texture image files (.jpg) in Agisoft (Build Texture...) to a value of 4096 px it worked! Supposingly, smaller values work as well.

Also, we were finally able to display texture in ArcScene when we had the exported texture split to multiple image files. This is an option in Agisoft when you build the texture. Although, we had problems with multiple texture files in ArcScene 10.1 it worked in 10.5.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.