0

I'm running into an issue that was not addressed in a previous question, but linked to a similar issue (ArcGIS modelbuilder: Iterate through Excel sheets?).

I'm using ModelBuilder to import .xlsx tables into Arc and turn them into point data.

My problem is not based in the naming of the outputs or converting the points to feature classes, it's actually linked between the Iterate Table tool and Make XY Event Layer tool.

Whenever I connect my excel workbook to iterate tables, the output table is directly connected to the make XY event layer (as seen in the first answer on the link) but does not seem to actually connect the table coordinates. In Make XY Event it has no X or Y fields to display. I checked on Esri's page on the tool and my data meets all the requirements for the tool. I even ran the tables separately in the tool to verify that they would work. Everything runs fine until the incorporation of the Iterate Tables tool. At one point it actually connected with no problem and then disconnected when I tried to verify the model. I can't seem to find the answer to why this is happening on google either. I'm fairly new to ModelBuilder so I'm afraid I'm just making a simple mistake with the iterate tool, but there isn't much to actually mess up so I'm stumped.

Extra details, the table used only contain Lat and Long data to minimize issues and I'm using ArcMap 10.2.2

  • 1
    Excel and CSV are not good inputs, try converting the Excel table to a DBF or Geodatabase table for more reliability. The reason for this is Excel is kinda squishy about numbers and text and will also allow invalid field names (spaces and punctuation) which you will have to fix to get the data into a more rigid table format. After that you shouldn't have too many problems. – Michael Stimson Jul 22 '15 at 3:21
  • Thank you for responding. I heard that converting to geodatabase table fixes most issues, but I was trying to automate a large task for people who know very little about ArcGIS and know a lot about excel. Also, wouldn't the individual sheets not run in XY Event Layer if there was an error within the excel tables? I could be wrong. – grahamfw Jul 22 '15 at 3:54
  • Excel is very forgiving with field names, and spreadsheets in general, it doesn't force you to have field names at all. In a real table field names are enforced - this is how Esri insists it to be. Field names also shouldn't contain spaces or anything other than letters and numbers (underscores accepted, not numbers first). By rigorously enforcing table structure at the Excel end you save a huge amount of angst, which isn't your fault, but that's not how the users will see it... trust me, it's always 'this junk tool' not 'my sloppy data entry' that the complaints are about. – Michael Stimson Jul 22 '15 at 5:08
  • Right, data integrity is a very useful thing though not everyone follows it since it isn't always needed (excel in many business applications). However, in the case of the tables I'm using they have two fields labeled "Lat" and "Long" respectively. The coordinates are in decimal degrees as well. I even tried condensing the tables so that they only contained 3 records each to make sure the data didn't contain inaccuracies. The problem persists. In this case, I feel that it could be the tool in this case on this computer. – grahamfw Jul 22 '15 at 5:30
  • 1
    Maybe you could import the Excel and CSV tables to fGDB tables as a part of the model (as intermediates). – GISI Jul 22 '15 at 7:31
0

I was able to get around the problem by removing all data from the spreadsheets except the xy coordinates and place each sheet of the workbook in their own .xlsx file in one folder to be iterated.

This was the only solution I found for my data.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.